Replies

  • My apologies if this has been covered but I have looked through the last forty or so pages and can't find any help.

    My set up: Pixhawk AC 3.3 - FrSky FLVSS - OpenTX 2.1 on a X9E with latest firmware - Lastest Clooney 2.1 with lua, compiled and uploaded with no changes to includes or defines. Telemetry set up as per Wiki on 9E

    Telemetry works as is should with lua script except for lowest cell voltage (Cmin) and distance/direction to home in lua screen.  All other telemetry values are transmitted and respond perfectly.  I have gone over, re-done and otherwise beat this to the end of my understanding for the last several days.  Could really use some help on this one.

    Thanks, RandyB

    • In the arduino scetch under the frsky sport tab, line 125 there is an option to select ac 3.3 or 3.2...did you select the right one?
      • Looks like 3.3 is default and 3.2 is commented out so I left as is.

    • Randy, On your telemetry sensor setup screen on the Taranis, do you have the Cmin sensor setup correctly? - If it is configured correctly, then with your Rx powered, and FLVSS correctly connected to s-port, plus LiPo balance connector connected to FLVSS etc, you should see the value of the calculated Cmin sensor displaying and updating on this sensor setup screen. If this appears to be displaying OK then check your spelling of the Cmin sensor name on this screen, as this is case sensitive in the LUA script, so its important its named with an upper-case 'C' and lower-case 'min'. The LUA script basically accesses this sensor data by name and displays the value directly onto the telem1 screen. If this is set correctly, and still not displaying, then can you make sure you are using the lua script from the s-c-l-v-rc-opentx2.1 branch, and not the -next branch (as this determines minimum cell voltage in the code and not through the calculated Cmin telem sensor)?

      I have done some testing on all these script revisions and I also do not have working distance from home, so you are not alone. Clooney is aware of this issue.

      Clooney82/MavLink_FrSkySPort
      This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
      • I only know enough about Arduino C to get myself in trouble but it seems to me that there needs to be a variable called 'Cell' to get single lowest cell voltage from the FLVSS and the 'Cels' to get the sum of all cells for battery voltage as we had in the original code.  Otherwise using the Cels you could only get battery voltage divided by the number of cells and that is not worthwhile info.  In the WIKI it shows 'Cell' as the source for 'Cmin' but does not give any setup for 'Cell'

      • Thanks Paul, I believe that I have everything set up right.  I had it working with the original Rolf teensy code and open tx but not after the switch to 2.1.  I have checked setup multiple times and still can't get Cmin to display on the sensor setup screen, all other values are live and working as expected.  I am going to spend a little more time on it this evening.  I'll post results.  Am I right that nothing has to be changed in the sketch if the FLVSS is used?  When I use Cels as the source I get battery voltage for Cmin.

        RB

  • I have APM 2.6 with 3.2.1 firmware and taranis with OpenTx 2.1.6.

    I have download : https://github.com/Clooney82/MavLink_FrSkySPort/tree/s-c-l-v-rc-ope... and send to Teensy3.1.

    In MavLink_FrSkySPort, change this:

    #define AC_VERSION          3.2
    //#define AC_VERSION          3.3

    and

    #define MAXCELLS 4 (4S Lipo)

    Compile ok,  but not work.

    In old versión "MavLink_FrSkySPort_1.3" led flashing in Teensy. In new versión led is ON.

    Please help me.

    Clooney82/MavLink_FrSkySPort
    This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
  • Hi,

    I downloaded the led-control tree https://github.com/Clooney82/MavLink_FrSkySPort/tree/led-control .

    I did everything as stated in the wiki using the Teensy version MavLink_FrSkySPort.

    If i comment the two led lines for led it compiles, but if i copy any led-control file one folder up it does not compile anymore.

    'get_gps_status' was not declared in this scope, if i shift the function over the function it gets called in this goes on with other functions.

    Can anybody help me, how can i get this to compile?

    Clooney82/MavLink_FrSkySPort
    This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
  • Well i'm looking for some help with the sounds pack .... 

    In the github there is the 3.3 sounds and the normal sounds 

    which do i put and where??

    I have this directory
    https://github.com/Clooney82/MavLink_FrSkySPort/tree/s-c-l-v-rc-ope... 

    in this folder on the SD card SOUNDS/en/TELEM

    i upgraded to 3.3 last night what do i need to do with the sounds now??

    do i remove the files in this folder on my SD card ( SOUNDS/en/TELEM ) and replace them with the 3.3 sounds??

    or do i keep the directory structure on github and create a new folder structure on the SD card 

    SOUNDS_AC3.3/en

    Clooney82/MavLink_FrSkySPort
    This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
    • This reply was deleted.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
12 hours ago
DIY Robocars via Twitter
12 hours ago
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…