• I have installed this on my teensy 3.1 and my taranis running 2.1.8, the telemetry seems to be coming through ok, but i do not get any audio notifications.

    I reads in the issues in github that mute has been added, I am wondering if I just do not know how to unmute?

    • Which version of the Telemetry code are you using? This one?

      Or some other - as far as the clooney82 version, I know nothing of a mute option to which you refer. 

      If yes to clooney82 version then:

      As far as sound files, there's a few pointers

      - do you have the OpenTX 2.1 sound pack installed on your SD card?

      - do you have the sound files from MavLink_FrSkySPort/Lua_Telemetry/DisplayApmPosition/SOUNDS_AC3.3/en/Ava/TELEM/ (or Samantha/TELEM/) copied to the path /SOUNDS/en/TELEM on your SD card? Thbis is where the LUA script looks for those files.

      This is all assuming you are using the Clooney82 repository, OpenTX 2.1.8 and AC3.3 or newer.

      Also, do you have all the telemetry sensors properly discovered? The sounds are based on the values provided by the sensors, so no sensor, no sound! All the info is available in the wiki here:

      (or maybe easier to read the updated Wiki, which I haven't yet published to the Clooney82 repository, from here: )

      This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
      • Thank you for your reply.

        I didnt have the OpenTX 2.1 sound pack installed, im doing that now (I have only just upgraded to 2.1 this evening).

        I note that you mention AC3.3 but i will be using the latest APM plane firmware, is this going to be a issue?

        FYI, Heres the info regarding mute

        Add a telemetry screen for messages, add mute option · Issue #27 · Clooney82/MavLink_FrSkySPort
        It would be nice to have a visual messaging system with the option of muting voice alerts. There are a few scenarios where voice alerts disturb the e…
        • After installing the OpenTX 2.1 sound pack I am now hearing some sounds, and flight mode seems to be working, but still Arming/Arming errors are not being reported.

          When i arm on mission planner, the taranis does report that its armed, but it also says "altitude hold" eventhough im only on stabilise.

          Any idea?

          • sounds like you are possibly using the copter217.lua instead of the plane217.lua. Also make sure you have all the TELEM sound files on your SD card as I suggested above. The latest version oin the Clooney82 repo has some additional flight mode files specific to the Plane firmware included, but you need to use the plane217.lua file for your telemetry screen - I included a new copy on my previous reply.

            • Hi Paul,

              Thanks for your hex and lua script. I have used these 2.

              I can confirm that when I turn off pre arm checks I get armed/disarmed reported on the Taranis as audio notifications (although when armed, it says 'altitude hole' straight after even when in stabilise mode?)

              I do not get pre-arm errors coming up on the Taranis though?

              They say a picture paints a thousand words, well a video is a series of thousands of pictures so lets hope these videos get my issue across-

              Telemetry screen and settings-


              Arming errors-


              Mavlink teensy taranis telemetry screen
              • Videos, definitely a good idea!

                The first vid - Looking at your telemetry sensors:

                No SWR displayed - that's strange as this should display as soon as you connect to your Rx.

                No Cels displayed - This would come from the FLVSS if you had one, and would give you access to individual cell voltages (and Cmin) - definitely recommended IMHO!

                T2 is reading zero - this is where the status codes and armed data is derived. Arm your plane and see if T2 changes to 1.

                Z1, Z2, Z3, Cmin - all blank as these are derived from the Cels value which is not getting data.

                For the second vid: Now I know I get pre-arm errors on the copter version of the LUA (with a teensy installed in my hexacopter running Copter 3.3.3), but to be honest I don't recall hearing any on the plane version (which I am running Ardupilot Plane v 3.5.2 and the plane217.lua). This is something I need to look into. Just for info, this project has been developed from the outset for Copter, and Plane only just happened recently when I spotted a need for it myself - I am still learning all of theTeensy coding, and trying to figure out someone else's code is always a challenge. It will happen though as I have plans for using the Teensy with an LRS system I'm planning to build at some point. To get the LUA working with Plane I had to make some modifications to the flight modes (as these differ from copter) - its also possible that the pre-arm status codes are different, so that may need looking into. Could take some work though! I'll have a look when I get back from holiday. Cheers

                • Hey Paul.

                  Im a bit happier.... I think i have it working, I used the MavLink_FrSkySPort.ino from github (although i assume this doesnt include your fixes/improvements you mentioned in the previous post) and uploaded it to the teensy using Arduino IDE. The reason i did this was so that i could change #define _MavLinkSerialBaud  to 115200 so that i can use it with the ULRS orangeLRS system which sends mavlink data over 433mhz as well as control signals, I have a x4r running CPPM firmware which also allows access to the SPort.

                  As soon as i turned it on i got the updates as you see in the video but also when i tried to arm i got the arming errors.... 1 issue... the arm errors do not read out once like i would expect, the arm errors continue to speak which is very annoying.

                  Am i right to assume that the errors should be read once, then wait for the next attempt to arm before reciting the errors again?

                  also, still not getting the SWR value coming though? bit funny as this is a different frsky RX.

                  Here you go... a video for you...


                  Mavlink teensy pre arm errors
                  • Interesting you are using this with ULRS - this is exactly the configuration I want to try (but HK seem to have no stock of the ORX LRS Tx modules).

                    I will look at getting the modified code up on the Clooney82 repository, so you can then change the baud rate and have the newer features (which is really only a working home Altitude).

                    As for the repeated messages, I will need to take a look at the LUA code to see how that voice message routine functions. I might ask Jochen (that's Clooney82) for his advice. If you could raise an issue for this on the Github repository - maybe include your video link, and it will keep us focused on looking at that?

                    Cheers, Paul

            • Thanks,

              I will try this tonight. I am sure that I was using the plane217.lua, but i will try yours instead.

              My Taranis is now running version 2.1.8, i notice that the .lua script is ..217.lua perhaps I should downgrade to 2.1.7?

This reply was deleted.


Santiago Perez liked Santiago Perez's profile
18 hours ago