I've got a stock 3dr kit that I've just finished putting together, and it tries to flip on takeoff. I'm running x config. Arducopter 2.1 firmware.

I've run through the troubleshooting steps: checked motors with the cli motors command (successfully), made sure the correct props are on each motor, calibrated the radio and verified that the correct inputs are reaching apm, but I still cannot get this thing to take off or fly at all correctly. Apm is facing forward between the front legs, and the movements seem to show up correctly in mission planner when I move the quad around while connected to it.

If I give it a smooth throttle increase, it won't take off flat, it will just tip, so I back off the throttle. If I give it a burst of power, it will take off, but will dive off to one side and crash (just busted my first prop...)

I've run the imu test with the following results:

g   0.0209   0.0000  -0.0000  a  -0.1157  -0.0463  -9.8016.

I have downloaded logs from the last couple of flights where it was tipping when I tried to take off, but I can't figure out how to interpret them. If anyone could give me a quick rundown of the best way to view/read them that would be good. I have attached the log.

Are there any other diagnostic checks that can be run to find out what's going on? I saw another thread where someone was checking the watts of power delivered by each esc to each motor to verifiy that a esc/motor not running at full speed wasn't to blame, but I'm not sure how this would be done.

Views: 14881


Reply to This

Replies to This Discussion

Also it seems like the hand test fails. I had a friend hold it while I set the throttle to about 25%, and moving the pitch and roll stick doesn't seem to make it tilt in the correct direction. Also after a few seconds the motors will go to full throttle without me touching the throttle.

I'm just looking at my mission planner now with the quad sitting on a level table, and under flight data with the tuning box enabled, I can see that the pitch is fluctuating quite wildly. The pitch climbs up to about 200, then drops sharply to -200 and repeats every 10 seconds or so. This behaviour seems to only be affecting the pitch, and can be seen in this log attached. I'm not sure if this happens every time.


To me, the title of this thread seems to suggest that many, many, many arducopters are prone to flipping on take-off.  I don't think that's fair/true.  If fact I think that in at least 90% of the cases arducopter is not to blame, but some setup error or another (non-arducopter) hardware error.

In the hand test, does the copter stabilise ?  I mean, if you try to tilt it by hand, does it resist and want to get upright again, or does it amplify the hand-induced tilt ?  If it resists in all directions, then motors, props etc seem to be setup correctly.

In that case I would carefully examine transmitter-receiver.  The fluctuating pitch ain't normal.  Motors going full throttle by themselves ain't normal either.

Are channels reversed ?  Did you calibrate radio correctly ?  In CLI go to test->radio and examine the output of every channel.  It should go from -4500 to 4500 on full stick movement, except for throttle, which should go from 0-800.  Values of 4450 are fine too.  Values of like 3000 are way to far off and you need to calibrate radio.

The values also shouldn't fluctuate more then about 10 if you don't touch the sticks.

What tx and rx do you use ?

I'm not implying this happens to lots of arducopters, I have just seen a few threads and, gone through the appropriate troubleshooting section in the wiki without a solution.

So I've just reset apm hardware and reflashed the 2.1 firmware on, and calibrated the radio and hardware again.

There are no channels currently reversed, and all channels respond as expected. I have tested the radio in CLI and the outputs are as you describe. I'm using a turnigy 9x with the stock 2.4g module and rx.

I've just given it another hand test, and it's definitely not responding how it should. For the hand test, I put the transmitter on the ground, give it 1/4 throttle and don't touch anything else. If I roll the quad left and right using my hand, motor 3 will speed up slightly, and motor 2 will stay static at low rpm, but there will be no real attempt by the quad to resist the movement, if I roll it to the right, motor 4 will do the same with motor 1 staying static at low rpm.

If I pitch the quad forwards (with my hand) motor 3 will increase in speed a lot, and try and pull the quad even further forward and will try and also yaw it to the right.

Pitching the quad backwards results in motor 4 exhibiting the same behaviour. Eg it will try to pitch even further backwards and yaw to the left.

Flipping at takeoff is almost invariably due to setup errors. Have you gone through all the Troubleshooting tests? Have you, for instance, run the Motors command in the CLI to ensure you've hooked up the motors right? Ensured that your board is facing forward and you've selected X or + mode properly? Checked motor rotation and prop orientation?

If all that checks out, check your hardware with the Tuning graphs in the Mission Planner. 


Yes I have been through the setup steps here: http://code.google.com/p/arducopter/wiki/AC2_Props_2

From a default setup, the motors test spins the rear motors when I move the pitch stick up, and the front ones when I move the pitch stick down, so I have reversed the pitch in the mission planner, and after that the motors respond correctly during the motors test. Am I right in assuming this can be taken as confirmation that my esc signal wires are connected to the pdb in the correct order, and that the correct escs are controlling the appropriate motors?

One thing I have noticed, is that there is a slight clicking sound coming from the ESCs when throttle is applied to the motors 1 & 3 with forward stick during the CLI motors test, also it appears during the motors CLI test, that the rpm is the front motors (1&3) doesn't go as high as the rear ones (2 & 4) from the pitch of the sound they make. I think this may be where the problem is.

Motor rotation is correct, and the correct props are on each one (and up the right way).

The APM/oilpan board is facing forward between arm 1 and 3, and X orientation is set.

What should I be looking for in the tuning graphs in Mission Planner?

No, that means that you've connected them to the PDB backwards. You shouldn't have to reverse the RC.

Hi Glenn,
I had this problem before and after a lot of head scratching I realised I had wired the power distribution board incorrectly. Basically the APM was firing corrective signals to the wrong motors. It might be worth double checking your wiring.

OK, I'm wondering if the 3dr build documentation is wrong. I followed it to the letter!

After you had fixed your wiring, what does the motors cli test give you? Do motors 1 & 3 spin when you move the pitch stick up (toward the top of the transmitter) as described in this page here?: http://code.google.com/p/arducopter/wiki/AC2_Props_2

What about if you put your roll stick to the left, do the left pair, or right pair of motors spin? I would assume the right hand motors should spin (1 & 4) but that page says that 3 & 2 should spin.


No. The wiki is correct. If I move pitch forward motors 1 & 3 will spin, back, motors 2 & 4, left, motors 3 & 2 and right, motors 1 & 4.

Hmm ok, so I have just double checked that my pdb is wired up as described in the 3dr assembly instructions pdf, and I have also checked that the connector from each motor's esc is plugged into the correct connector on the pdb. I have attached an excerpt from the docs I looked at showing how the pdb is connected to the apm.

In the bottom diagram from the wiki, R corresponds to motor 1, L with 2, F with 3 and B with 4. Is that correct?

Running the motors CLI command with it connected as described this way, when I push up on the pitch stick, motors 2 and 4 spin, and down 1 and 3 spin. Left 2 & 3 spin, right 1 & 4 spin.

I've also noticed that in the mission planner under the flight data tab, if I tilt the quad forward and back it will show on the display that it is moving correctly, but if I roll it left or right, the horizon will move the wrong way.

What else can be checked?


Actually scrap that horizon comment, that's correct behaviour and shows that the APM is oriented properly, but does anyone have any ideas about what's going on here?

Have you tried swapping the connections of your motors on the PCB ?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service