I've got a stock 3dr kit that I've just finished putting together, and it tries to flip on takeoff. I'm running x config. Arducopter 2.1 firmware.

I've run through the troubleshooting steps: checked motors with the cli motors command (successfully), made sure the correct props are on each motor, calibrated the radio and verified that the correct inputs are reaching apm, but I still cannot get this thing to take off or fly at all correctly. Apm is facing forward between the front legs, and the movements seem to show up correctly in mission planner when I move the quad around while connected to it.

If I give it a smooth throttle increase, it won't take off flat, it will just tip, so I back off the throttle. If I give it a burst of power, it will take off, but will dive off to one side and crash (just busted my first prop...)

I've run the imu test with the following results:

g   0.0209   0.0000  -0.0000  a  -0.1157  -0.0463  -9.8016.

I have downloaded logs from the last couple of flights where it was tipping when I tried to take off, but I can't figure out how to interpret them. If anyone could give me a quick rundown of the best way to view/read them that would be good. I have attached the log.

Are there any other diagnostic checks that can be run to find out what's going on? I saw another thread where someone was checking the watts of power delivered by each esc to each motor to verifiy that a esc/motor not running at full speed wasn't to blame, but I'm not sure how this would be done.

Views: 14803

Attachments:

Reply to This

Replies to This Discussion

Need to add a positive note here- I just got the motors and prop adapters for my quad and I am pleased to say that everything is now working exactly per spec. 

It did not go perfectly smooth.  I had to deal with a few issues that might have caused flipover if I hadn't had it tied down to my work table. 

1- I had #2 and 4 motors reversed on the APM.

2- I thought I had calibrated and set up my ESC's, but screwed up along the way and had to re-configure two of them to get the same startup and timing as the other two- wish I'd bought the programmer card.

3- I hacked my transmitter (mode switches, throttle changeover) and forgot to re-calibrate throttle and modes after reassembly.

4- Due to above, I had the mode set to RTL instead of stabilize and the throttle wouldn't respond

Its really cool holding the quad and feeling it try to compensate for me moving against its will- and moves lotsa air too!

Yeah I have tried swapping the connections of 1&2 and 3&4, but that doesn't help.

Ok , so latest hand test, when rolling the quad to the left by hand, motor 2 increases in speed to compensate, and when tilting to the right, motor 1 increases in speed. This is correct behaviour yes? 

The thing is,  it appears motors 3 and 4 remain at constant rpm no matter how much the quad is tilted either way. What could the cause of this be?

Eric: Thanks for the update! Great to hear that it's all working now, and kudos on your patience in working through the setup mixups.

I had a similar problem yesterday.On takeoff the quad always tried to flip as soon as the throttle reached 50%.

Doing the hand test, when I roll it left or right I always felt the Quad fighting it. But when I pitch it, forward or backward, I did not fell the same force, actually there was almost no resistance to pitch it any further.

I finally went back and re-calibrated my ESCs again (see below). This fixed all my problems.

Up until yesterday my quad was flying really nice and stable. But unfortunately due to my clumsiness I crashed. Well it was not the first time, right. So I checked to make sure all is still nice and tight and tried to take off again. Well, it did not work as expected. Motor 2 did not want to spin up right. Found that one of the wires coming out of the motor broke inside.

So I suspect that when one of the motor leads broke, the ESC calibration somehow went out the window and had me scratch my head of what's wrong with my quad.

P.S. The reason I went back to recalibrate the ESCs is that I finally got out my RPM meter and checked the props. There I found that one prop was running about 50% faster then the rest.

The lesson learned her for me was, check and double check everything. Then check what was not checked before (the prop speed in my case).

OK this just gets weirder. I pulled the whole thing apart, checked every connection, recalibrated the ESCs and gave it another hand test.

At 25% throttle, the hand test fails. Motors 3 and 4 are doing all of the work when the quad is rolled or tilted, and 1& 2 do nothing (other than maintain a low rpm).

However at 50% throttle, all motors work properly. In the hand test it fights every pitch or roll change off centre.

This isn't how it's supposed to be right?

Any ideas why at low throttle a couple of motors don't seem to be responsive?

Glenn, it sounds like it's close or may already be working. Do you know what step ultimately led to the quad finally fighting your hand movements.. was it recalibrating the ESCs or just getting it up to 50% throttle?

I know on quads I've setup in the past that at low throttle, the hand test isn't always very illustrative of what's happening even when the quads are known to fly well. If you're going by sound or sight it can also just be really hard to tell what motors are responding.

At this point, after the working hand test at 50% throttle I would try to fly it again, but maybe tie it down somehow so it can't flip if you want to save your props.

Unfortunately I have been unable to successfully repeat that hand test. The thing that really gets me, is that the behaviour isn't always repeatable, and I'm not sure where the problem could be because of this.

Last night after the successful hand test, keeping all connections exactly the same, I powered it off, plugged the lipo in again on a flat surface, and then instead of trying to maintain a flat orientation it wanted to roll strongly to the right.

Hand testing it this morning, it seems like motors 3 and 4 are responding correctly, but motors 1 and 2 only increase or decrease in speed when the throttle is manually changed. The fact that the speed of motors 1 and 2 are changing with throttle input makes me believe that the connections from the APM through the PDB to the ESCs are fuctional, otherwise the motors wouldn't be able to have their speed controlled at all.

I think I may have made somewhat of a breakthrough, but I'm not sure how to verify it. During the hand test, if I rotate myself (yawing the quad) different sets of motors will start to respond when the quad is deviated from flat. So in the above scenario, where motors 3 & 4 were responding correctly before, rotating it will make motors 1 & 2 start to respond, or a combination of the 4 but it still never really wants to stay flat. Does this mean that I could have a faulty magnetometer?

It sounds like your quad is in simple mode, which could have been confusing earlier before you knew that.

http://code.google.com/p/arducopter/wiki/AC2_Simple

That probably explains the strangeness in which motors were responding earlier. Simple takes its orientation on being armed and calls that direction forward, it then mixes your stick inputs automatically so that the yaw of the quad doesn't affect the direction it flies when you move the stick in any direction.

No, your IMU is working correctly. It's all about how the machine is oriented when you plug in the battery! As soon as you plug in the battery, Home orientation is set. So if it's not dead level, or in the orientation you intend to take off from, it will attempt to go home (oreintation) as soon as you give it throttle. Thus, if you had it tilted the instant the battery is plugged in, holding the machine level in the air would only power 2 motors at low throttle settings because it wants to level the frame (or not level depending on how you look at it). Further, rotation in any direction, will cause now the machine to attempt to correct that orientation as well. By all rights, it's acting 100% normal, it's your faulty startup routine. Also, HIGHLY recommend plugging into telemetry at startup where you should verify the machine resting at level is also sensed at level! I "zero" my machine each time I fly to make sure this doesn't happen.

 

Also, this happens to my RC helis as well. Even y CX-3 coaxial must be in a "correct" orientation when I plug in the battery, and remain there for a couple of seconds while the gyros take their intitial read. Otherwise, I will fight the gyro the remainder of the flight. It's easy to show because unplugging and reseting will make the problem go away.

What might be nice is a "reset" or "level" button on the IMU board or external rather than the current method of connecting with telemetry. It's not always easy to plug in, and not disturb orientation, but we also don't want a "switch" in the current path either. It's also scary to have ESCs powered and the ECU not, so there's really not a good safe way yet unless somebody has an idea? Being we have a requirement for some serious amperage and ultra reliablility, switched power just isn't practical. Alternatively, non BEC ESCs and a separate BEC regulator might work on a switch, but is more complex and might cause other issues we haven't even imagined yet.

It sounds like it's in simple mode, but it's definitely just set to straight stabilize mode without simple enabled.

I've got it sitting on a flat bench here and connected to mavlink now, and the compass is constantly moving, and the roll is also moving quite a bit. I think this is where all my problems are coming from, but I don't know if it's indicative of a bad compass, APM or something else? I have attached a screenshot

Attachments:

Everything is absolutely dead level when I plug it in. I am 100% aware of the requirement for this. Even running a level command while it is sitting flat on the bench and switching back to the flight data tab, the compass and roll still show that they are moving.

The compass movement could be caused by some other electronics in close proximity. If it's sitting on a level bench and ends up with that huge bank without you moving the board at all then there is something wrong with either the gyros or accelerometers. Get in touch with help@3drobotics.com (I would refer you but it's best to start communicating over email). Give them a link to this thread and I'll fill them in.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service