Another uBlox GPS question

Hola Amigos, I'm having issues with my uBlox GPS.  I've taken a lot of time reading the instructions and reading other's posts regarding their problems before deciding to post here.

First off, I built an adapter cable to be able to test the GPS via u-center and the FTDI cable.  The GPS works properly when directly connected to my computer (u-center is really nifty, btw).   I updated the firmware to latest version and have configured the GPS to communicated at 38,400 baud and followed the other instructions that Jordi describes elsewhere on the forum (http://diydrones.com/profiles/blogs/wiring-up-ublox-only-for-pros ).  I cannot get a GPS lock when I connect it to the Ardupilot shield (blue version) nor to the ATMega328 board.  I've been connecting the GPS via the uBlox adapter (from diydrones) and the uBlox adapter cable.

Other than the GPS not connecting, the rest of the autopilot seems to work properly (fbw, etc).  Oh, I've tried several versions of the ardupilot code to see if that's the problem.  It doesn't seem to be.

After looking at the instructions and reviewing the adapter, I have a couple of questions.

The manual shows a 3.3V connector for GPS/Modem ( http://ardupilot.googlecode.com/svn/images/twentytwo.jpg ). Should the GPS also be connected to Ardupilot Shield from this connection? I've tried this using the pins I added to the bottom of the adapter to make a connection and it still doesn't work. I'm assuming the uBlox adapter cable was meant to bypass the need for connecting to the 3.3V GPS/Modem pins but just double checking.

On the back of the uBlox Adapter board there is selector for >5V and 3.3V ( http://store.diydrones.com/v/vspfiles/photos/BR-0008-01-4.jpg ).  It looks to me like the default selection is >5V (middle pin and the one closest to >5V are soldered).  Is this correct if the GPS is to be running at 3.3V?

Any suggestions on how to proceed?  I'm perplexed and hoping there is something obvious I'm missing.

Thanks,

Mark

p.s. I'm trying to get GPS lock with a clear line of sight to the sky and I've tried the GPS test utilities (Raw_GPS_Tester and uBlox_Tester).

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Group:  

    I had an issue with the GPS connection yesterday.  Several test missions were aborted because the aircraft was not following the mission.  Everything looked normal on the ground; GPS locked, flight plan reset, etc.  However after landing from one of the aborted missions, I noticed there was no GPS lock.  The Ublox GPS connector into the APM 2.5 appeared to be fully seated however I attempted to push it in further.  Nothing moved, clicked or indicated that the connector seated better after pushing it, but the GPS then began to work so I am confident the proble  was caused by a loose connection.  

    In review of the Tlogs, a couple of the missions indicated loss of GPS lock. The loss of GPS was both intermittent and permanent.  But the loss of GPS lock in the HUD display during the playback of the Tlog, did not indicate a loss of GPS lock as frequently as I had problems following the mission.  With this in mind, is it possible to loose partial connection but not loose the indicated GPS lock on the HUD display? 

    What can we do to ensure positive lock between the APM 2.5 and the Ublox GPS?  As mentioned above, there is no positive click to ensure it is properly mated.

    Lastly, for those of you who have been following my challenges in getting the APM to correctly follow missions, this may hav been part of my problem all along.

    Thank you.

    Bret C

  • I am using a Ublox gps, i have use the ublox gps test for the APM.

     

    I have read from serial monitor and i received all this... Is it correct for indoor? Was the GPS working? Cause when i use my modified code for arducopter, the GPS module is power up but the led is not lit up and shown on IMU. 

    3692146684?profile=original

  • Thanks for the input everyone. I figured out my problem after extensive use of a multimeter and magnifying lens. It looks like the pins between the plastic female connection for the 6-pin GPS cable and the ArduPilot board weren't originally soldered. It's possible I somehow damaged it, breaking this connection but all the pins looked clean of solder... After a very careful soldering job, I retacked the pins to the board and the GPS is now connecting properly. Yippee!

    Does anyone have a simple solution to avoiding damage to these connectors?

    Thanks,

    Mark
  • Developer
    If you are using the adapter board then it takes care of the 5v to 3.3v conversion. You only need to use the solder jumper if you are going to be powering the adapter board from a 3.3v source.

    One known issue is that if you are using the adapter board but power it from a 3.3v source (without soldering the jumper) the ublox will operate but will not get a lock. This does not sound like your case - you are using the adapter board and the 6 pin cable from the store to connect between the adapter board and ArduPilot, correct?

    I don't hear anything wrong in what you are doing. You might try inserting a couple Serial.print statements into the gps parser in the ArduPilot code to see what is going on....
  • 3D Robotics
    Where did you get the uBlox? From us? If so, did you request that it be programmed?
This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…