APM 2.0 Ardupilot 2.50 failsafe setup

I need some help setting up and testing failsafe. Here is what igot so far:Rutabaga 8J when switched off the throttle ppm drops to 911 as seen on Mission Planner. I think I may have the settings in MP param not set correctly. The online infor for failsafe seems to be a little different than what I am seeing in MP. Does anybody have the current settings for setting up throttle failsafe? Also is there certain conditions that are required to have the APM revert to RTL? Please help with how to get the MP Parameters for failsafe set correctly and any requirements to test it on the ground before flight?Thanks for the help

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi

    Even though I have problems now this is how I got it to with on my Futaba.
    Your PPM value seem ok but verify that THR_FS_VALUE is set. Should be higher than your 911 uS. Also verify that THR_FAILSAFE is set to 1.

    If you fly in the lower modes such as MANUAL, FBW, STABILIZE etc and lose link then after 1 second, APM will switch to CIRCLE-mode. After 20 seconds (failsafe_long_on_event) it will switch to RTL-mode and come back.

    In AUTO mode it will do the same as above if you set FS_SHORT_ACTN = 1 AND FS_LONG_ACTN = 1 - otherwise it will continue in AUTO mode. Setting these two value to zero (0) will keep you plane on AUTO mode. I want mine to continue in AUTO but cannot get it to work with my OpenLRS receiver.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25