Wiki Ninja

APM 2.0 Dataflash issue. Help needed.

Hello guys,


Has anyone encountered any problem with the dataflash of the APM 2.0? I just found out I have an issue with it when I first tried to download the logs my flights from the APM planner Terminal tab. I was not able to download any flight log so I tested the logging from CLI; alas it told me no dataflash card found, even though it was firmly inserted on the APM. When I removed and reinserted it, the APM 2.0 would not initialize and just freeze. So I took the card out and the  APM functions without the dataflash card inserted; I believe there is some sort of a shorting in the terminals of the card or its reader. All the while I was flying with the dataflash card inserted firmly but had no contact with the reader.


I got the APM 2.0 from the first batch on the last week of Dec 2011 and have couple of flights with it(here) but no crashes, whatsoever.  The card is important for the next wave of firmware upgrades as announced by Chris A. I would appreciate if anyone could shed light on this.





You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello!

    I have an APM 2.0 since April and today I got a problem with the memory card. I use the board to acquire data and perform logs in the memory card and today after using the APM I got home and to download the latest log I connected to APM Planner and when entering the CLI when initiating communications I got the following message in the screen: 
    "No memory data flash inserted"
    The memory card is inserted all the way in and it worked out fine until today...
    I still can see and download all the logs that are in the memory card but the big problem is that with this error logs are deactivated and APM don't save data. 
    What is the problem? 
    What can i do? 
    I am using APM Planner 1.1.92 and the firmware in the APM 2.0 is ArduPlane V2.34.
    Best Regards
    André Marques
  • Wiki Ninja

    Received my APM 2.0 from 3DR today, was very excited to connect to the APM Planner to upload the latest code. I downloaded the latest APM Planner 1.1.60 then connected the APM via USB. Alas,  I got timed out with MAVLINK and then then I got this error notice:"No heartbeat packets received". Tried changing to another cord, hoping that there is something wrong with the previous one. Tried again, same error message.

    I read the details and synch the baud rate of 115200 on both the mission planner and COM Port property of my APM 2.0. Tried connecting again; still getting the same error message.

    Read the details again then waited for the GPS to lock (solid blue light at GPS daughter board) and mowed the front lawn/ backyard. Got back and connected the APM 2.0 to the planner: same result- no heartbeat packets received.

    Now I'm puzzled. Whst is wrong with my APM 2.0? I noticed that when connected to PC via USB cord, the blue and red LEDs are flashing alternately with the yellow LED. Can that tell me something?

  • I had a similar problem as I was never able to access logs.  From CLI it also told me no dataflash card found.  I removed it and reinserted it and CLI was then able to at least see the dataflash but anytime I browse for logs there are none. Logging is enabled.

  • 3D Robotics

    Please contact 3DR tech support:

This reply was deleted.