APM 2.5 Connects to computer but doesn't connect to mission planner

Hi I'm using Mission Planner 1.2.10 with MavLink 10, I hook up my board and can't connect. I'm selecting the correct com and baud rate (115k). When I go to my device manager it does show up as Arduino Mega 2560. When I switch the tab to the firmware tab on Mission Planner and try to upload the arduplane firmware I get an error saying "Can't detect APM version. Please check your cabling."

Any ideas??????????????????

Views: 8431

Reply to This

Replies to This Discussion

Julio,

The good news is your computer at least sees the connection. Is this APM2.0 or APM2.5? (should function the same but..)

I would try other COM connections as indicated below...

 

The extreme possiblity is a loss of boot loader in the APM but...not likely. When you connect the USB cable, do leds on the APM light up? If so, the base code of the APM is probably fine. This implies the boot loader is probably fine.

-=Doug

Hi Doug,

 

Thanks in advance for the reply.

I'm using the 2.5, and I set it to the correct com port based on what is in my device manager (and it's the only option on the drop down menu you have a picture of) and I have the correct baud rate (115k). The lights do light up, but I can't seem to get a connection.

 

I've gone as far as trying to reupload the code to the board, and it seems that everything goes ok until I get to an error message while uploading (I started a topic on that as well here http://diydrones.com/forum/topics/ardumega-code). I think my last shot is to reload the bootloader : /

Are your PCs port settings correct?  On my Win7 laptop the first time I connect the APM board, the default speed is 9600 not 115k.  Occasionally it reverts back to 9600 and I have to set it again.

Yes I checked before trying to upload the code to the board, correct com port, correct baud rate. I tried shutting down unplugging everything and redoing the whole thing again just for kicks, and still same message. 

I do notice that the RX and TX leds aren't lighting up too much, I imagine they would be on since code is literally being sent there....only the RX led occasionally pulsates on and then off about every 3 secs. 

I'm having exactly the same problem with a APM2.0 that was working fine. Now it doesn't connects, checked all just like Julio did, and same problem. I didn't do any changes, it was working fine and now ???.

Any help would be really appreciated.

 

 

Check your solders.  I had this exact same error and went back and double checked solders and noticed that I had missed one.  I fixed this and reconnected.  Everything worked fine and I was able to download the firmware.

Thanks Logan, will see more closely, but it's not probable since I have never disassembled it, and the problem has been progressive. Started to happen a few times, then it just doesn't work, so it may be something else.

I think this board is just dead.... will see,

thanks again

 

Hi,

Did any of you with that problem by any chance cut the track at the PPM-PPM solder jumper? Like when you want to connect a receiver with a PPM output using a single cable?

I had an APM2 that would also not connect or program, same symptoms as you describe. It did show up OK in Windows device manager, and testing with a scope on the UART0 pins revealed that data typed in a terminal program did arrive on the UART pins of the little auxillary ATMega, the one with USB.

Then I went crazy with the scope and ohmmeter, and finally found out I had cut one more neighbor track, barely visible, when opening that PPM-PPM jumper. Reestablishing that broken connection fixed it....


Regards

Soren

No I didn't cut that jumper.

Someone told me it may started to get some rust in it, so I'll clien it with alcohol.

It seems to have hapenned before.... I don't know until I try this. I don't have anyother explanation.

Cheers,

YEPN I GET THE SAMR AS WELL SINCE I CALIBRATED THE ESC CANNOT CONNECT TO THE APM TO RECALIBRATE RADIO
TIMES OUT NO HEATBEAT RECEIVED I USE 1.2.2 latest version re installed wipe all out about 4 time tried various version SAME

is the board F..... yet all led are ok tried to reset hardware but not sure if it is correct just to press the button on power up ??? there could be a trick.....
looks like board is locked in firmware ant suggestion before I burn the full thing.!!!!

Mauricio, 

Have you tried re-uploading the code? Not just updating the firmware, but actually using arduino to reload the source code to the atmega? 

ok I have the same  probleme

tried all the baud rates and all port No luck....

I assumed a hardware problem  may all voltages are ok   but diode D4 did blow

so it could be firmware indeed  but how do you do this ????

could spikes or transient do this to the firmware..?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service