APM 2.5-Getting Logs-Need Help

I have a new APM 2.5. I am using, right now, Mission Planner 1.2.12 and running Arducopter 2.7.3.

Everything seems to be working ok except the altitude so I  wanted to get some logs to see what's going on. I go into the terminal mode after connecting and all is well. I can do a screen dump of any of the 21 logs that I have. When I go into the Log Download it tells me Error Opening Comport even though it is already open as I can do a screen dump. When I close the error box the log window opens with no logs. What is causing this error? I know the communication is working as I can do all the commands that I want until I try to get to the logs. Whassup?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I’m having this same problem but my work around is not having to shut down MP but knowing if I’m going into Terminal to retrieve the logs, I click the Terminal button the second time once confirmed connection is good the first time.  Once I’ve seen the Terminal connection screen twice, then I click on the Log Download button and it works no problem.

    I'm running Windows 7/64 and no need to be in administrator mode.


    This is a little annoying until it can be fixed, but better than shutting down MP.

  • I had this issue last night.   However I think the issue is unrelated to admin access.

    It appears that having the mission planner connected is causing problems with the terminal session.  Mission planner connection is occupying the com port when the terminal try's to connect.

    By shutting down the MP and reopening, the terminal will connect....UNLESS you connect with the mission planner first.


  • I have the same problem trying to download the logs, "error opening com port". If I run the Mission Planner (1.2.14) as an administrator, then it worked.

  • Developer

    can you post a screen shot or similar

This reply was deleted.