I've just received new APM 2.5. When testing its log data seem problematic: altitude mix and altitude GPS are of very high value, about 170 m although I tested on the ground. Then I tried to install a new Mission Planner, version 1.2.22, but the PC can't connect to APM 2.5 board again

Can anyone suggest an idea?

Views: 1706


Reply to This

Replies to This Discussion

Hi, what platform have you installed the APM into, Plane, Multirotor Traditional Heli?  

Also do you have a telemetry radio installed?  If not your computer may have assigned the com port to a diffrent number.   If a windows computer check under the device manager for the correct com port and ensure that it is set to connect at 115200 

I don't have telemetry installed. It's shown after MP is installed that COM3 is Arduino MEGA 2560 with the speed is set to 115200. I have the Plane platform.

Try reassigning it to a higher COM port number in the Windows Control Panel.

The issue is solved. I read in Arducopter about first time APM 2 connection and updated the USB driver to Arduino MEGA 2560.inf then all work again. Now I'm testing log to see if altitude is correct

I walked with APM 2.5 but the recorded altitudes were so high. I highly appreciate any idea to explain this issue because with these altitude data it's dangerous to fly


I did the same actions again, re-installing MP 1.2.22 with the hope that it would read correct log data. But again the PC can't connect with APM 2.5. Only after I've updated USB driver to Arduino MEGA 2560.inf the PC can connect again. It's a feeling that PM's USB driver is not good for APM 2.5 and may be because of this it reads incorrect log data as I already tried 2 GPS and when connecting to PC without GPS lock the altitude coming from pressure sensor is drifted but only in the range of some meters

Guys, I had the same issue after installing the MP 1.2.22, very difficult to connect after the update, but it eventually managed to connect after PC restart and several attempt...

BTW where have the "reverse" checkboxes gone in Radio Calibration ?? I was playing with that just before the update, but now I seem to be reversed and don't know where to change it...

(APM 2.5)

I tried again, and I confirm that I now can't connect any more :-\

Is there any easy workaround ? do you really have to update the Arduino mega 2560 driver ??

Guys, probably my mistake, my APM2.5 was stuck in ESC calibration mode (just like http://diydrones.com/forum/topics/stuck-in-esc-calibration) and couldn't get out, whatever I did...

Had to install ArduPlane, then reinstall Arducopter (reset of the EEPROM?) to get out of this ESC calibration mode, and fix my connect problem.

Manu: We disabled the reverse checkboxes for ArduCopter because they're dangerous for multicopters. Instead, you should reverse channels on your RC transmitter side. 

And I would say that you should not need to reverse the channels in your Tx either.  All the channels should be going in the correct direction, with the exception of possibly the throttle channel which is reversed on some transmitter, such as Futaba.  Futaba always has 1900 pwm when the stick is down, and 1100 pwm when the stick is up.  I don't know why but that's what they did.  So, to fix it, just reverse the Channel 3, or throttle channel.

We decided to remove the channel reverse from MP because it is more confusing than anything, and should not be necessary.

Almost everything solved. When testing log function, I didn't wait for GPS lock, so the home altitude is set to 0.This way, instead of relative to home altitude, the altitude data are ASL, that's why they look so high.

Reply to Discussion


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service