APM 2.5 Not connecting in APM Planner

I recently received a ArduPilot Mega 2.5 and have had some issues getting it to work correctly. 
Firstly I plugged it into USB and when it first ran it had the default test menus in the serial terminal. I proceeded to upload new firmware using the Mission planner 1.2.11 (ArduCopter V2.7.3 Quad to be specific). The firmware uploaded without error and I can access the CLI interface. When I try to connect through the connect button in Mission Planner, it stalls at "Already Got param STAB_D" or "ACRO_P" or similar messages
Then I get the "Connect Failed" with the details of:
Timeout on read - getParamList
Received:241 of 245 after 6 retrys
I've tried the other firmwares available and they all stall at a similar message. 
Another thing I've noticed is when I try to run test -> ins through the CLI interface, it does not show me anything except for:
"Hit Enter to exit.
InertialSensor"
Then does nothing indefinitely, so I can't read the IMU data through the CLI interface. After I did this, I soldered some pins onto UART2 to test if UART0 and UART2 were streaming serial correctly, and they both stream numbers at 115200 baud correctly without error.  
I've only soldered the jumper pins and 4 pins for UART2/+5/GND onto the entire board and have kept the device in the static bag up until I used it, so I cant imagine any hardware damage has happened since arrival a few days ago. Any ideas on how to fix this problem? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • hello,

    i have a problem with my apm2.5
    i connected my apm with >5v

    mavlink from usb and telemetry can't conected

    but FBW and manual mode is normal

    how to fix to conect mavlink?

  •  Looking at all these post it looks like quality control missed a few.....  Im experiencing the same thing, looks like the gyros out of the box where malfunctioning. 

  • 3692574450?profile=original

    My APM 2.5 also hangs .... LED C"blue" lights, but LED B & C are off .... I am able to upload firmware so I believe that bootloader is working...

    it seems I have an issue in Baro or Gyro .... I believe that because of attached CLI test.

     

    3692574594?profile=original

    When I go to Flight Data all data is ZERO ...

    I believe the system hanges when initializing IMU 

    Kindly advise....

  • Hi all, I'm a newbie on the community writing from Argentina. A couple of weeks ago I've ordered by very first APM 2.5.

    I have a similar behavior to the one described here. I'm able to upload the latest ArduPlane firmware(2.65) and access through the CLI, but connection fails always saying: "Timeout on read - getParamList. Received: 224 of 238
    after 6 retrys... ".

    Using the CLI, test of the GPS works well but test of the IMU hangs initializing Gyros.

    I'm sending a full description of the problem to 3D Robotics but it seems I will need an RMA.

    Its a little disappointing for me to start like this...

  • Hi Greg,


    I have the exact the same issue with my new APM2.5 board.

    I can upload arducopter V2.7.3 but when trying to connect, it always ends with a connection error.

    Here is the resulting message:

    3692506052?profile=original

    Did you have any luck with yours yet?

  • The uart 0 is  switched between the usb and the telemetry port if you see the data stream at the serial 0 but not usb

    it may be the usb circuit is bad . When usb is not pluged in   the baudrate is switched to 38400 baud  and you can run the CLI through the serial port.  This is the fix for apm2's with broken USB connectors that were beefed up in 2.5

    It will not  have the reset function  so MP firmware update does not work  and you will have hit reset button to get arduino to upload

     

     

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Sunday
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…