APM 2.5 still won't arm my ESCs, I give up!

Hi,

I posted on here some time ago saying that my APM 2.5 wouldn't arm my ESCs (red light continues to blink). At the time i was using DJI Opto ESCs and I kind of put the problem down to them. So i recently purchased some nice new HobbyKing ESCs with SimonK firmware. Finally found the time to install them, and to cut a long story short .... still nothing but i blinking red light.

I'm using the latest Mission Planner (1.2.61), latest Arducopter firmware (3.0.1). Have made sure everything is calibrated (it tells me that the calibration is successful), made sure my DX8 radio is calibrated properly and that no channels are mixed up - low throttle position reading 900 on the calibration page. Yet if i try to arm, with or without it plugged into the laptop via USB, it won't arm!

Yes i've read all the guides and Googled the hell out of it, but regardless of what i try it just won't play ball.

Frustrated.com!!!!!!

Is there a chance the board is faulty? I'm 99% certain i'm not doing anything wrong. I've been over everything at least 10 times to make sure it's not me.

Cheers.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • jut had the same issue. found it was that compass offsets were too high. no idea how. So I used log calibration from previous flight to set er up and bingo!

  • Hi Jake,

    Have you tried to connect one esc at the time directly to the receiver? Will it arm then? This will show if it is APM related problem or not.

    Regards Jani

  • MR60

    Hi Jake,

    To help you , are you certain you went through these actions :

    -live calibration of your APM accel (through mission planner) : v3.0.1 will not arm if you did not do this

    -Compassmot procedure (through command line interface) : v3.0.1 will not arm if you did not do this

    -Your APM should be fixed faraway enough of your ESCs and motors and power distribution board because version 3.0.1 does compass health checks before you can arm (APM should be installed a few inches above these parts)

    -Radio calibration : ok you did it, should be fine (V3.0.1 will not arm unless you did it)

    -Geofence should be enabled in mission planner : v3.0.1 will not arm unless you did it

    -The voltage of your APM should be within the 4,5-5 volts range : V3.0.1 will not arm if this is nit the case.

    Take a look at https://www.youtube.com/watch?v=gZ3H2eLmStI for a video from Randy about these pre arm checks

    Hope this helps

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…