APM 2.5 with AV130 Savox servos

Well I've been reading and trying everything I can find but no success. Here is what I have.Hexa with APM 2.5AV130 GimbalGimbal has Savox servos.No matter what I try the setup fails.1. Tried plugging into the RC11 directly which causes APM to reboot and momentary movement from the servo.2. Signal only to RC11, power to external BEC which results in the servo jumping all over the place, going "dead" then jumping some more.3. Signal line to RC7, power from external BEC, again servo jumped all over the place.4. Signal line to RC7, power from RC11. Continuous error beep.I connect the servos to a receiver and everything works fine. I can connect other digital servos to the APM and it works fine.Connecting the Savox servos in any configuration fails. But works fine on a receiver including a micro receiver.Is anyone successfully using a AV130 with Savox servos connected to the APM 2.5?David

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Just in case it helps anyone else out.

    I solved my issue. The problem was a combination of things.

    When running off the RC11, the amp draw was just enough to brown out the APM because the Savox servos use a "pot" for position sensing. When combined (servo and pot) it was to much of a load.

    While using a external BEC the problam was caused by using a secondary power source with no common ground to the APM

    Solution is to use a BEC connected to the output rail (RC1-8) from a seperate power source, or RC11 signal only with the BEC drawing power from the PCB. My solution was to create an artifical BEC through the servo leads to provide power to the RC1-8 rail as I had used all the ports.

    If anyone wants additional detail or pictures feal free to post.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25