Hey guys could really use your help here. Building first quad.

I have the APM 2.5 and had the mission planner installed all working fine, Usb from laptop to APM and would connect. Was simply waiting for my transmitter and receiver (Spektrum DX7, Ar8000) to be able to do anymore. Once I binded the receiver to the transmitter I went back to the laptop to do the rest of the checks but now I can't even connect now?

I get 'No Heartbeat Packets Received' so a little confused whats the problem? It connected fine last night, I had the AR8000 connected to the APM for power when binding.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Was this ever resolved? I am having the same problem

  • Yes im having the same prob.
  • I had / have the identical same problem.

    Reverting back to MissionPlanner 1.2.76 solved it, thanks.

    Interestingly this problem occurred on system using windows 8.1 and usb 3.0, I also have MissionPlanner latest version installed on an old Netbook running windows XP, which has not shown this problem even with the latest rev of MissionPlanner.

    I'm guessing its a USB timing problem associated with one of the USB drivers that's enclosed in each MissionPlanner.msi file.

  • Update for anyone interested:

    Running an older version of MP solved my connection problems (version 1.2.76 worked in my case).

    Something seems to have been broken since that version; the MP developers might want to take a closer look into this issue...

    If anyone needs the older installer, PM me, and I'll provide a download link.

    Thanks a bunch to @Antonio for providing the older installer...

    • I am new to this, but have been reading some of the discussion.  I am also having the same problems with the new MP.  Could I possibly get an older version (1.2.76) download link from you also?

      Thank you,


  • Hello, I'm new here...

    I'm having almost the exact same problem.

    This *appears* to be an issue with Mission Planner and connecting via USB, perhaps one of the recent updates broke something? I know it sounds strange, but here's why I think its due to MP (at least in my case):

    • when attempting to connect Mission Planner via USB, the APM board appears to go into some kind of 'reset' state; the status LEDS shut off (except for the 'alive' power LED)
    • once I abort the connection attempt (or allow it to timeout & fail), the board will almost immediately boot (status LEDS begin their boot-up flashing sequence, everything works normally)
    • The only times that I *am* able to successfully connect via MP + USB are when the board doesn't go into this 'reset' mode during the connection attempt (i.e., the LEDS remain on as the connection is being established)
    • I have to try like 10 times in order to force it to connect through USB, although it's pretty random; sometimes it takes much longer, sometimes is connects right away...
    • I have no problems connecting to MP via the 900Mhz radio, so the UART circuit itself *seems* to be ok (though I'm no expert)... I can always connect without a 'reset' (or whatever it is that's happening through USB) by using the radio.
    • I have no problems connecting via USB & MP in order to upload firmware; haven't had a corrupted or failed firmware upload
    • I can always connect *successfully* to the CLI via USB, either via MP's terminal, or any other terminal app (i.e. hyperterminal)
    • it makes no difference whether I power the APM only via USB power or with external power (lipo power), it displays the same behavior
    • nothing has changed in my hardware setup, and no damage has been done to my board. The only changes that have occurred were a few MP update installs that I allowed through...

    Is anyone else experiencing these symptoms?

    Since I don't own an official 3DR board, I can't go to them for hardware support.

    Still, I really think that this should be a software issue (based on everything I noted above).

    If it doesn't end up being fixed, I'll be forced to connect via radio from here on out, or struggle trying to do the brute-force connection via USB.

  • Oh sorry I never answered this. I got in contact 3dr and they sent me a new one and I returned my old one. Have not tried the new one thou as I am in the middle of moving houses.

  • Hi Warren,

    Did you ever solve this problem as i am having exactly the same issues. 

    If i load version 2.91b using MP then i can connect at 115000 on COM11, if i then load version 3.01 i cannot connect using same baud and port.  Does 3.01 have something extra in the firmware its waiting for before enabling mavlink?? If i go back to 2.91b then again i can connect.


  • Admin


    I had a connection problem like you have and I found that I needed to use a powered USB hub to connect to the APM because the APM was pulling more current than the PC/laptop USB port could supply and the voltage dropped below 4.0 vdc.


    TCIII Admin

  • I can update the firmware on the APM, and I can connect via the terminal. So maybe there I can do something?

This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022