Hi, i'm having some trouble installing firmware on my APM 2.6 .  My computer recognizes the device in the devices control panel (Arduino Mega 2560 COM 5).  Next I go to the the mission planner to select the COM port i want.  I select COM 5. It does NOT say "Arduino Mega 2560 COM 5" as some tutorials i've seen have, just COM 5.  Finally i go to "install firmware" and select ArduPlane.  After taking a very long time to load it says "Communication Error-No connection"  at the end.  I've attached some screen snap shots showing the different steps I took.  Any advice would be great!   

Views: 1052


Reply to This

Replies to This Discussion

All I can think of is to try uploading the firmware using the Arduino IDE?

I installed Mission Planner on my other laptop and it worked.  It showed "Arduino Mega 2560 COM 5" in the drop down menu instead of just "COM 5" like my other computer.  I tried reinstalling it, but to no avail.  I'm thinking it might be some sort of driver problem? anyway at least I know its not my board.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service