APM 2.8 and GPS / Compass


I've done lots of thread-searching but haven't found a fix; any help would be appreciated.

I am in the process of upgrading from APM 2.5 to APM 2.8. My problem is that I cannot get the GPS / Compass to work. It is (they are) a Ublox Neo module(s).

The MAG jumper next to the GPS connector is removed but even with it place I get 'Bad compass health' in Mission Planner.

I have plugged in two different GPS/Compass modules: one gives 'GPS: No GPS', the other 'GPS No fix'. I am unsure whether plugging them into the flight controller has friend them - the power LED's are unlit.

The compass connector has been pugged into the I²C connector and the connector below the GPS connector.

The connector is inserted like so:



I am sure I must have missed something obvious but I'll be blowed if I can work out what it is...



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I'm having a slightly different problem with APM 2.8, Arducopter 3.2.1, and an external pole-mounted GPS/Ublox Compass module on a 155 hex.  Using Mission Planner I am unable to get this external compass to calibrate. 

    The jumper has been removed (which SHOULD disable any on-board compass), APM 2.5 is selected as the F.C. type (there isn't a selection choice for APM 2.8), and the external compass is selected as the compass to use (all on the Compass Calibration screen).  I can hit all the white dots on the 3D display that you see when you aim the front, right side, back, left side, bottom, and top at magnetic north and rotate around the L-R axis (like the YouTube video shows). and I can get a fairly well spread out pattern of "hits" showing on the 3D display.  However, when I click on "done" MP immediately pops up a window in which it says "Compass Calibration failed!"

    I've tried allowing MP to automatically extinguish the white dots as I hit them, and I've tried doing it by disabling that feature and hitting them manually by myself.  The first method usually times out before I have hit all the white dots, but the second doesn't have a timer associated with it, so I can take a little more time to get them all.

    The sad thing is I DID get the compass to calibrate about a week ago, but now it won't (no changes have been made to any hardware since then).  The only thing different is that I went into the firmware and changed the MOT_SPIN_ARM value from "70" to "0" (to stop the motors from automatically spinning upon arming the copter).  For some reason that change never got from the Mission Planner screen to the FC EEPROM when I hit the "write params" button (what DID happen was the copter no longer arms properly (the red light on the APM turns solid red, but only for a second - then it goes back to flashing) and the motors don't respond to throttle inputs. 

    I've re-uploaded the firmware that I was using last week to the EEPROM, but I still get the same results.

    You can call me "Frustrated and Confused!"

  • You checked the external compass box on mission planner?
  • I too, am at my wits' end with trying to eliminate the BAD COMPASS HEALTH warning on a brand new 2.8. There is very little posted on You Tube that solves the issue. There is a post that pointed out a new jumper on the 2.8 board, next to the GPS port. The poster stated that removing the jumper disabled the on board compass. I found BAD COMPASS HEALTH with jumper in or out, and could not get north to be north on my Apm. I've about had it. I had the same issues with a 2.6 board, that never has flown either. I did the jumper severing thing... nothing helped the Compass situation.

  • Pat Roy said:

    I have had to check both boxes (internal and external)  in the mission planner to get mine to work even when I removed the jumper.  

    Could you tell me what boxes your talking about and where I could find them? Thanks.

  • Hugh, did you ever find a solution to this? I'm having the same exact problem. Tried the i2C port and the side port by the top GPS port and still no joy. I have a M8N GPS module, and the Arducopter with side ports. I've tried with the J2 jumper in and out. I noticed the head of the GPS is warm, but no light is flashing in it any more.

  • I have had to check both boxes (internal and external)  in the mission planner to get mine to work even when I removed the jumper.  

  • Basic Question, but have you calibrated the compass?

    • Thanks All,

      I tried Nicks suggestion of tweaking the Ublox software and APM21 - no change. It started working when I moved everything back to the APM 2.5 board, did the same update and then moved things back to the APM 2.8 board. 

      Thanks again, I got there in the end.

      - Hugh

      • hey Hugh, would you mind sharing your progression before and after progression?

        as i have the same issue with my NEO 6M GPS module, its is a China made as i bought along with APM 2.8 (China made)

  • APM2.8 GPS pinouts:

    3702207921?profile=originalTry to change Rx Tx.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile