APM 2 GPS not getting a lock?

I have been sitting here trying to get a lock with my GPS while outside for about 10 mins.  No luck.  I generally get a lock between 30-60s when outside.  My GPS has worked fine previously.

Other than the CLI test (which only works if I have lock anyway), is there a way to check GPS function?

If my GPS unit turns out to be no longer functioning, what options do I have with the APM2?  Since my GPS is soldered directly to the board, is it possible to get another and use an extension?  I don't trust my soldering abilities enough to remove and replace the current unit

Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Also suffering with this problem...2 APM2's 2 APM1's all suffering this with MTK units.


    Swap in a ublox...i get lock sub 20 secs...MTK is very random...

    i think that this problem is more endemic to the GPS NOT the code....#

    Would be realy great if anyone official would answer this...or at least the correct process to disable the MTK so we can use another GPS the right way....

    I have also posted elsewhere with no official reply...in fact no reply at all...

    IMHO, so many people are suffing this problem (if you read across the forums), that ignoring the masses will end in upset, given that we have all paid for these units with no reliabilty, or more over explanation or interest in the issue.

    (just to explain my previous statement: I have no issue with code issues, thats what we are here for, to learn, grow and enjoy. Screwey hardware is unacceptable, as we buy trusting the designers, that the hardware is trustworthy)

    Our fearless leaders really need to chime in here.

    Kind regards,

    Mike.

  • Mine did work fine with the 2.5 FW, only 2.6 that I have issues with. Anyone from 3DR want to pipe up and give us some guidance?

  • I have the same problem, I have two APM2 and one APM1 all with mediatek GPS, and powered with CES.

    • APM1 work fine.
    • A APM2 didn't lock GPS  (30min) and I thought this was because the power wires and canopy block the signal, therefore I cut a path of integrated GPS for canceled it, and I conect a external gps. With this, all worked fine.
    • The other APM2, I have installed in a clear place in the plane and the gps no lock (30 min).


    I'm going to try power by the USB.

    I think this is a serious issue, because our boards are garbage if don't lock the GPS.

  • Yep, I'm the same. 2.6 FW, no lock when self-powered, but full lock fairly quickly when fed by USB. What the??????

    I see Andreas posted:

    "Comment 9 by  project member  andreas@antonopoulos.com, Jun 4, 2012

    Problem indicated solved. Not software related "
    But I've no idea how to find this resolution. Anyone?
  • Has anybody tested it with an older firmware than 2.6? Maybe it´s a software issue.

  • It downloading the almanac again just have it sit outside for hour or two. Once you get a lock you can unplug it then repower it should get a lock 30-60 sec. I had this problem before and realized this helped.

  • I have the same issue: GPS-Lock only when powering via USB. Is there any solution meanwhile?

  • I went out tonight for the first time to fly my APM2.  I waited for about a half hour under clear skies in the middle of the country to get a GPS fix and couldn't.  My cell phone and car GPS each had no problem finding 7 satellites.  This was with my normal flight power system - LIPO connected via ESCs.  So I went ahead and flew (not a bad maiden!) and 15 minutes later when the battery was low, I noticed when I landed that the GPS blue light was on solid.

    Just out of curiosity, after totally powering down the craft I plugged it back into the USB to see if I could get satellites.  I waited about 20 minutes and it had still found only 2 satellites.  I went and flew two quads and sure enough, when I came back about a half hour later it has a GPS fix.  I then flew it and played around with loiter (and had more issues, but that's a separate topic).

    Am I REALLY going to have to wait 45 minutes for a GPS fix every time I want to fly this thing?  Grrr....

  • I seem to every now and again get a lock on the GPS, but not on the APM2 itself... a reset seems to clear this.

  • Contrary to my previous comments on this issue, I withdraw my comments of "Mines fixed" and repost as "still suffering" and, I am sure this is a power related issue. Having used the J1 jumper solution I posted earlier as a work around never getting lock, last night while doing some bench work, I noticed a glaring difference between the GPS operation under different powering conditions.

    If I power the APM2 with the USB, as I was for grabbing logs and setting parms, I get a quick strong lock with the on-board GPS, 7 - 9 sats in under 2mins, cold start, in my shed, with spaghetti junction around the APM as it always is with my builds. 3DR telemetry radio (915) is running, although with nothing to talk to, minim osd is also powered up although the Vtx (1.2/500) is not powered up.

    I now disconnect USB and power unit with the flight pack LiPo. The front end of APM is powered from a dedicated Ubec, via the dragonlink Rx. The output rail is powered via a CC 100amp ESC BEC. Again 3DR telemetry is running, in this case it is talking to the ground station unit, again Vtx is not powered. Dragonlink Tx is a good distance from aircraft to eliminate any interference it may produce. I can not obtain a 3D lock in this condition.

    My thoughts:

    1. Noisy power? I doubt it's any more noisy than USB power, video/osd show no signs of bad power when running. Is the USB port any more filtered than the input/output rails?

    2. 3DR telemetry is having an effect while locked/communicating with ground station? I have tried with air module disconnected and although I could not see sat number or hdop, the lock light never went solid.

    3. I have exactly the same GPS module within 30mm of the APM unit, used as a stand alone GPS receiver for my AAT, it locks solid every time, from the same power supply.

    I don't really have a direction to head with this now. I think it is time to hack the board. Piggyback the Tx line from the AAT GPS onto the Tx trace of the APM GPS??? Reckon that will work? 

    The subject has gone fairly quite, given quite a few members show signs of these symptoms, and solid GPS lock is reasonably important. did I miss a fix on this? The link to the issue raised, has now been closed as "Not software related".

       

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…