APM 2560 not receiving data from RX

Hi All,Setting up a brand new combo of APM 2560/Oilpan for use with arducoptermega.First, when APM is connected to USB it is not able to power on the radio receiver... I have checked that APM inputs power pins have 5V and that at the end of the cable it is also 5V, but the receiver does not power on....I have checked the receiver separately with a BEC and it powers up normally, indeed if connected to an ESC BEC and use radio throttle the motor spins. So the receiver works ok (also tried with different receivers but same result).Also impossible to receive any value in CLI/Configurator/Mission Planner from the receiver, even when powering the receiver separately with a BEC and connecting to APM inputs only receiver data cables.I have tried ArdupiratesNG and ArduCopterMega with the same result. No radio inputs.I have also checked the soldering and cables and everything appears to be ok.I appreciate some help from the community.Thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • On newer boards, the Radio and Servo's are no longer powered by USB, so that is normal.

    The BEC powers the radio and servos via the APM servo rails, but the APM still needs power when not connected to USB.

    So youll need to attach power input to the APM board next to SJ1.


    See pics halfway down this page.



This reply was deleted.