Hi All,

I have an APM 2.5 board (brand new), it's my second APM, I have another 2.5 in an aircraft, this one is for a quadcopter.

I've loaded up 2.9 through mission planner, all good.  Then power cycled the APM and checked everything is fine, I can connect just fine and get telemetry through 3DR radio and/or USB.

HOWEVER, when I connect my RC receiver up, it works ok and powers up, all good.  But as soon as I turn my RC transmitter on the APM hangs, crashes or whatever you want to call it.

I can be connected via Mission Planner and receiving telemetry fine, then when I turn my Tx on everything stops.  The orange lights at the front of the APM flash rapidly and the ABC lights either go out, or display a solid Orange.  I've tried all different combinations of power up cycles to get around the problem and nothing seems to alleviate it.

I have a 3DR power module powering the RX, APM and GPS, I do NOT have JP1 connected as per instructions, and the output stage only has the BEC's from the speed controllers on it along with a roll servo for my GoPro mount.

I've tried;

- Powering the whole thing from a seperate power source and removing the 3DR PM source

- Powering up the RX, turning the TX on and then powering up the APM

- Powering up the TX, then the electronics

- Powering up the TX, then the RX, then the electronics

I've also tried a completely different radio system, including a different transmitter and receiver.  When I use these, the APM doesn't even boot up, regardless of whether the transmitter is on or not.  The whole thing just goes lights out including the GPS.  Which is different behaviour to the original radio gear.

Basically I think I've tried all sorts of combinations and permutations to get this thing working.

All that being said, I've actually had it going once, and was able to calibrate the radio, and program everything up and fly the quad.  However, after I changed the battery over, it went back to this.

Reading through the forums I found "similar" issues, but nothing that seemed to describe exactly this scenario.  I have tried flashing and reflashing the firmware, and also got it going once by flashing another firmware (ArduRover) and then flashing the ArduCopter again and it seemed to work but I've not been able to repeat that.

I would welcome any ideas, or similar experiences, I think I may have to return the APM perhaps?

Many thanks

Biggles.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • T3
    What radio are using? Can you provide pictures of your hookup on the APM?
This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Apr 11
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Apr 11
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Apr 11
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
DIY Robocars via Twitter
RT @chr1sa: Maybe we should have a mini @DIYRobocars race in our lower school's playground https://t.co/xLFeua1R6X
Mar 29
DIY Robocars via Twitter
If anybody wants to join us for an informal outdoors hack/race we're going to be meeting at the @CircuitLaunch park… https://twitter.com/i/web/status/1375907409223249923
Mar 27
DIY Robocars via Twitter
RT @SmallpixelCar: Ready to reopen, innovation has to continue. Inside/outside, LiDAR/GPS, race/delivery https://t.co/jpmvttoHEd
Mar 26
DIY Drones via Twitter
RT @DAVGtech: By far best race yet! Congratulations to the winner @Heavy02011 🥇🏆🍾👏👏👏 @diyrobocars @donkey_car @NVIDIAEmbedded https://t.co/…
Mar 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #8 - #ParkingLotNerds ⁦@DAVGtech⁩ ⁦@DWalmroth⁩ ⁦@OttawaAVGroup⁩ - join us tomorrow h…
Mar 20
DIY Drones via Twitter
RT @mrpollo: 11 years ago, the pxIMU was announced to the world on @DIYDrones, and it changed the life of many (mine included). The followi…
Mar 18
More…