APM Copter 2.9.1.b has been released


APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey Randy,

    Loaded the latest firmware 3rc5 on my tricopter. 

    Noticing a toilet bowl effect when in loiter mode after may be 20 seconds or so into it and also after pitching forward. 

    Uploaded the files for your analysis.  The first minute or so the compass live calibration was being performed.

    Hope you can assess what's going on. 


    2013-06-06 06-50-31.tlog

    2013-06-06 06-50-31.rlog
  • I'm getting ready to update an octo from 2.9.1.b to 3.0RC4. Other than what Randy has already mentioned is there any other parameters like in Rate and Stable that should be adjusted:

    Randy said:

    Loiter Speed P: 1.0 (was 0.2)
    Rate Loiter P: 1.0  (was 5.0)
                     I: 0.5  (was 0.04)
                     D: 0.4  (was 0.0)
                     IMAX: 4.0 (was 30.0)
    Altitude Hold: remains at 2.0 but many people will need to reduce to 1.0 (or even 0.5) to reduce jumpy alt-hold

  • Hi Randy,

    Here's my experience with the APM2.5 + PM on 2.9.1b.

    I had RTL fly away on 2.9.1b which was due to PDB inteference. The following solved it,

    1) reallocate PDB interference

    2) manually enter declination

    3) compass live calibration

    4) compass learn turned off

    On 2.9.1b, i didn't do Compassmot due to not able to arm as soon as i entered terminal, blue n red LED would shut off. Then i did radio calibration after your viewed my log the other day.

    Then i moved to V3rc4, first impression was good! motor startup was much softer, forward flying was smooth. Althold and Loiter seems better as well, no wind at all at that time.

    Then at V3rc5, i lowered the Loiter speed and rate as you suggest. First flight on stab was ok, but it was rolling to left. And in Loiter it would slowly yaw to left.Then at one time when i punch the throttle in Loiter, it would start to "toilet bowl", that means compass having inteference right?

    So i thought, "Hmm. i should do the Level calibration and Compass calibration again".

    Then I did the following,

    1) entered my manual declination, -0.6 which it would change by itself to -0.58999

    2) then i perform the CompassMot when i noticed my magfield is bout 256 when the "Pre-arm check" video says it should be 330. the outcome was that my magfield became 350! so i perform Compassmot again, this time it became 380!
    I check the flight data, at the "Quick" tab, my Yaw reading is nervous and not pointing correctly, similar like when it had compass inteference last time.

    * PM was disconnected since APM connected to USB, so current reading wasnt accurate as pic attached.

    3) So i perform the Manual declination and live calibration again. this brings my compass heading to much more steady and pointing at the right direction relevant to iphone as comparison. however the magfield goes down to 217.

    So tried Loiter again and oh boyyyy. i had massive toilet bowl everytime i engage loiter and it get worst... batt reset doesn't solve.

    Attached are some of the files. Hope you can look into it and point to me what gone wrong. Never had such bad loiter before.



    live calibration result.JPG

  • 3.0.0-rc5, seems to work OK on my QUAD

    Not so good on a HEX, Radio calibration at times does NOT see yaw moving even though the channel is moving in Raw Sensor View Radio. It usually will not arm because it doesn't see Yaw at all times, it is randomly seeing yaw.

    The pre arm warnings ONLY EVER APPEAR ONCE and NEVER AGAIN as if it stores somewhere the fact it has displayed it once and bad luck if you missed seeing it THAT ONCE in Mission Planner because it will NEVER be displayed again.

    When it does see yaw and manages to arm, with throttle down, it arms and spins 2 motors with throttle still all the way down.

    On the same frame radio etc none of those issues occur once it is set back to 2.9.1b

    I am using a PWM Receiver with a separate lead for each channel

  • I've been testing loiter in 3.0-rc5. It's rock solid just sitting there, even in wind, but it seems to have a serious bug that occurs if you do any extremely aggressive maneuvering while in loiter mode, where it immediately cuts the throttle and drops out of the sky. It's a very repeatable bug too, I've already managed to crash this same way 4 times, in total breaking 4 props and a CF landing strut. To cause the bug to occur, simply move the pitch and roll stick rapidly in various directions while in loiter, and the bug will happen within usually less than 10 seconds; seems like an especially large gust of wind can trigger the bug as well. In software development, easily repeatable bugs are usually easy to find and fix, so hopefully this can be fixed quickly.

    Log attached. Issue occurs on line 2375, where throttle out spikes to 1000 for an instant, then drops to 130 (every log where the bug occurs follows this same exact pattern), causing the quad to fall onto the ground on it's back. At this point I was already back in stabilize and gunned the throttle, but too late, the props spun up only to break on impact with the ground.

    I hope this can be quickly resolved.

    2013-06-06 15-19 4.log

  • Yesterday I did some tests with my TBS (firmware 3.0rc3).

    I wanted to test the RTL and mission planning behaviour.
    I must say that I'm impressed, it works very nicely.

    I tried several RTL's including landing and all within 1m of the home position :-)

    Next stop was the mission planner.

    I set up a small mission of 5 waypoints incl takeoff and landing, worked flawless.

    Developers did a very nice job, thank you for that!

    Today I will have a go with the 3.0rc5 as I read there is a fix on motor pulsing in Althold/loiter (same as Marco showed in his video on the 3.0rc4

    My setup:
    TBS Discovery

    MT2213 - 935kv motors

    20A ESC (SimonK flashed)

    3300mAh - 4S

    APM 2.5 (3DR power module) with Ublox

  • Guys, this might just have been dealt in this topic but it has become so big that I might just ask, in case it hasn't...

    I'm going to update very soon my 3DR hexa with the latest 2.9.1b firmware. I have a UBLOX Lea GPS and an MTK one:

    • MTK: I know I have to update it to version 1.9, but could anyone point me to the latest and easiest method for that ?
    • UBLOX: do I have to update this one ? if I have, any resource to do so as well ?

    Once I have updated my GPS(s), will they be ok with Arduplane latest version (2.73?), which I also share GPS with...

    Thanks guys!

  • Is beta v3.0.0rc5 available to use?  I understand "at your own risk".  I'm wondering if it is a full functioning firmware available for anyone to try.

  • My altitude is reading erroneously . I have my copter sitting on my dining table and it's reading over 300 ft. I'm not using a sonar. APM 2.5 is stock with case and foam covering the baro from 3DR.

    Is there way to calibrate the altitude or barometer?

  • First, I'd like to thank the dev+test teams for delivering the goods! Sunday I did some 3rc4 testing, and for the most part everything went perfectly. My video shows excellent loiter & circle performance in medium wind (~10mph). I forgot to change circle to auto before I left for the field, so I didn't get to test that. :P Also, I had "a GPS moment" (@4:42 GPS signal drops while in loiter):

    All I asked was gradually slow down and left yaw... the rest was commanded by GPS. You know, that loss of control could have ended a lot worse. This is the second time (of ~100 flights) this has happened to the quad, and the first time damaged some parts. Here is proof my uBlox was to blame:

    3692735552?profile=originalI did have GPS failsafe enabled, but clearly it was never called during that loss of control. In this case I was flying rc4 with a mission loaded; so I am glad it did not enter LAND, but now that rc5 fixes the LAND bug I want my GPS failsafe to work. I haven't looked in to the GPS failsafe part(s) of the code, but I'm very interested in changing it (or parameter ;) ) to be more sensitive... it should not be trying to fly itself around crazy like that.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile