APM Copter 3.3.2 help with Compass variance

Hello,

I'm having a battle with my compasses. I use pixhawk clone and M8N GPS with compass.

I'm unable to find orientation setting, where I will not have EKF compass variance errors.

I think that this is not mag interference problem because this happens when disarmed.

I've disasembled external GPS/compass puck and there are following axis markings:

           x axis

z axis  O------->

           |

           |   y axis

          V

My APM configuration is in the attachments, and also example values when facing north.

Do I have faulty compass? or I've tried wrong Orientation settings?

compass1.png

compass2.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had a very similar problem with my M8N & Pixhawk

    Here is what I noticed:

    1. When indoors and you do not have a GPS FIX and you have the internal compass also enabled you get the compass variance message. Once you get the GPS fix the message goes away.

    2. For al practical purposes I always disable the internal compass. I think the general consensus is that its useless. Once you disable it you should stop receiving the compass variance message even when you do not have a GPS fix.

    • Finally the weather and work allowed me to go out. Compass health is much better when GPS is Locked. So i assume this issue is fixed now.

      Thank you for tip with disabling internal compass :)

  • please send pictures of our quadcotper

    ps : Boulanger and Patissier, good team !

  • Michal,

    Is your compass mounted upside down?

    Regards,

    David R. Boulanger

    • I don't think its upside down. Pixhawk is inside the frame mounted pointing at front, and compass is with arrow forward. The board inside is mounted (as it came from factory) 45 degrees turned (like an diamond) but compass chip has also arrows pointing as I wrote in original post with Y axis backwards and X axis to the right.

      IMG_3596.JPG

      IMG_3595.JPG

      • Well...  In the screen shot you posted you had roll set to 180.  You may want to change your COMPASS ORIENT Parameter to 0 and see if that helps.  I'm not sure why the Y axis arrow is backwards or if it has anything to do with the problem.  If it did then when you pointed north it would say south.

        Regards,

        David R. Boulanger

        • Thank you David for such quick responses :)

          I've set Compass_orient for compass1 to 0, and raw values from both compasses seem pretty close, but EKF does not aproove.

          compass3.png

          https://storage.ning.com/topology/rest/1.0/file/get/3702807195?profile=original
          • I'm not sure but I noticed you did not have a Gps fix.  Is the big square part of the GPS (Antenna) pointing up .  I honestly don't know if not having a good GPS fix will cause the variance error to appear.  The EKF may require a good fix to prevent the error.

            Regards,

            David R. Boulanger

            P.S.  Just trying to help the best I can

            • By the way is there any method how can I find out what is correct compass_orient setting for my compass?

              I've tried the hard way - change compass_orient - reboot - calibrate compas - reboot and compare both compass raw values via status page.

              • Usually, there is a small hole in the compass component to mark a direction - it's depend of the manufacturer but if you know the reference, you should be able to find it.

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…