APM gets lost & drifts 3km - how to get logs?

I have Mission Planner 1.3.37 build 1.1.5917.13431 for Windows running on Windows 10

The dos "MP boot" terminal says I'm running ArduCopter v3.2.1:

INFO MissionPlanner.MAVLinkInterface - 6/14/2016 11:26:52 AM 1 ArduCopter V3.2.1 (36b405fb)
INFO MissionPlanner.MAVLinkInterface - 6/14/2016 11:26:52 AM 1 Frame: HEXA

I connect the APM to my computer via USB

I click on "TERMINAL" in Mission Planner (tried connected in "FLIGHT DATA" first and again wihtout connecting there and the result is the same)

Default Text:

3691303209?profile=original


I click "Connect" in Terminal:

3691303130?profile=original

All the garbage in the above output shows only a few characters at a time once every few seconds.

What I'm trying to do is collect the logs but selecting "Log Download" from terminal opens a new window where more garbage characters are slowing displayed. "Download All Logs" nor "Download These Logs" respond at all.

3691303143?profile=original

The reason these logs are so important is because my APM disconnected from my remote and drifted 3km until the battery died and it dropped to the sidewalk. Someone found it and reported it and the FAA number traced it back to me.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Did you understand if it's a human error or related to HW/SW?

    • I don't know too much about the logs but it seems like the log process may have been interrupted since the drone went down due to battery failure.

      What I know is that I had the drone performing autotune in alt-hold and after a while it stopped early and then started to drift slowly. I worked all the switched on my remote but by the time I went to try and catch it it was too high.

      As far as I know you have to set the flight mode to autotune and set half throttle in order to initiate autotune. I also know that alt-hold has done this to me before but I think it's an issue with my remote.

      notes:

      - I've had this happen before a couple times in alt-hold where I get an unresponsive drone. To disable it I have to unplug the battery in mid flight.

      - I disabled the failsafe modes of RTL/land because it would interrupt the autotune so in a way I was asking for something disastrous to happen. Never again..

  • My log skills aren't sufficient to offer much advice.

    But others on here can, and will, if you can get their attention. You should consider posting on the Ardupilot forum, too - the recommended spot for specific appeals for help.

    If your drone knows where it landed but not where it took off, my first suspicion would be lack of GPS 3D lock before take-off. Maybe combined with triggering a failsafe in the air.

    Do you have the means to confirm GPS lock before take-off? (such as - activating pre-arm checks in the parameters, so that arming without GPS lock is impossible. Or the pattern of lights on the GPS that confirm lock. Or telemetry radios that show you the Mission Planner data during flight.)

    George

  • You're using 3.2.1 firmware.

    I'm not sure it even supports log download via Terminal anymore (?)

    Did you try the newer procedure? - on the Flight Data screen, below the HUD, select Dataflash Logs tab, then 'Download via Mavlink', etc, etc.

    (I suspect this isn't what you meant by 'tried connecting on Flight Data screen before going to Terminal for logs'.) 

    Try getting the logs themselves from the Flight Data screen.

    Of course, after a serious crash, the card could just be toast. 

    George

    (PS - I tried via Terminal after loading 3.2.1 and got gibberish)

    • I looked around for a while in case there was a "new" way but I completely overlooked this way. I was able to download all the logs, now to figure out how to view them.. Thanks for your help and I'll post back once I know what happened!

      • I'm looking at this log and the GPS isn't completely accurate. It shows about where it landed, but not where it took off. I'm currently viewing this with TERMINAL > Log Browse. This is my first time browsing a log so I'm not sure exactly what to look for. Anyway, here's the log in case you or anyone wants to peruse to see why the copter drifted off on it's own.

        http://cl.ly/3v0g3m02273l/2016-06-09%2015-20-34.log

This reply was deleted.

Activity

Jørn Ramnæs liked VIDEO LINK's profile
Friday
Mark Harrison left a comment on Moderators
"Wow, Ning2 looks really great on mobile. I had sort of drifted away as my browse-time went more on my phone, so this is great."
Friday
Hank Deucker left a comment on PIXHAWK
"I am sure most will say not again, Pixhawk telemetry. I do need help and all can be reassured that I have spent many hours scouring the net for useful information. I am not new at quadcopter flying, I started in 2012 and have progressed through many…"
Thursday
Hank Deucker left a comment on PIXHAWK
"Tomorrow, I am thinking about the wording at the moment."
Thursday
More…