Does anyone know; Is the APM misison planner available (in whatever form) for a mac? 

How awesome would it be if there was an ipad app (and interface for telemetry) made for it... talk about a great solution for the field. If I had the programming skeelz....I'd do it. But I can barely tie my shoes. 

Views: 27451

Reply to This

Replies to This Discussion


I'm a Mac User. I had a poor experience with Mission planner on my Lion/VMware/Windows 7 setup. I had a lot of writing/ verifying errors when working the APM Firmware. 

I had better results with an Atom card in an old PC box at home but no way to have it at the flying site. So I purchased a 10" portable Atom PC at a bargain price and I use it for that purpose.



What you are lookign for is the QGroundControl application for MacOSX. It is a full mission planner and MAVLINK GCS. However, it does not "flash" firmware for you, for that you need MP or you can use the Arduino IDE or command line (avrdude) on the Mac.

Lion, VMware Fusion and XP works great with MP. Much better than Paralells or any combination with W7

Awesome- thanks
I'll check that out
How is the user interface compared with the MP?

It is different. MP is for single-UAV control, QGCS can do a "fleet" of them. MP is single window view, QGCS has floatable windows and a customizable set of views and widgets (you can make it look like you want). Honestly, I prefer QGCS for "power use", but MP is definitely best for new users and simple scenarios. It's really a different design for a slightly different audience. 

Then again, if it helps me avoid running Windows ever again...

Hi Scott / Marc -

I recently wrote about this very issue in the forums:

I need to post a followup, but I wanted to briefly let you know that I was successfully able to run Mission Planner on a Windows 7 Boot Camp install on a MacBook Air (Lion). Loading firmware and verifying it also works. I'm running Tiny7 (a popular stripped-down Windows 7 install) and I wouldn't recommend it - use a full Windows 7 install and save yourself many frustrations. Tonight I finally got my first Hardware In the Loop simulation working with X-Plane while booted into Windows.

Not surprisingly, when I then tried to use VM Ware to load the Boot Camp partition as a VM, uploading firmware fails again. My experience has been that I can use MP in a VM to consistently connect via USB or XBee and inspect params or monitor a mission, but not load firmware. As a side note, I could never get X-Plane to work from within a VM either (I guess that's to be expected).

Given that the XBees worked from within the VM, it might be an option for use as a GCS if the firmware is already loaded. But booting into windows seems uniformly better.

Hey Michal, Was considering giving this a try.  Any issues I should know about?  Thanks.  Ben


can you help me to connect virtual box XP running on osx , my USB recognizes the arduino hardware, but i cant connect the COM4 port that mission planner needs , 

i have tryied many different configurations with no success.


Hi Gustavo,

Did you set your baud rate in XP for the arduino device? It should be 115200 for USB. 


yes i did , in is ok

im intalling again the ftdi drivers, 

just to try again ...

is working now after reinstallin ftdi , with /dev/cu.usbmodemfd131  as parameter on com port4


I run Mission Planner great on my iMac 27" and my MacBookPro 13". On the iMac I have Windows 7 running under bootcamp, and on the laptop I have XP running under bootcamp. Both setups work great, can flash, etc.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service