APM v1.? having some issues

Hi all, I bought a used APM for a fair price with had a broken oilpan (the atmel dataflash IC is ripped off :).

anyway im fairly good at soldering so there will be no trouble physically replacing the part.

Im running some tests to see what shape this board is in and have a few questions. Previously I've only been using the APM2.5 hardware, but it "flew off into the woods" and I never recovered it, so Im unfamiliar to some of the stuff regarding this older HW. Mine came with Atmega 2560

Here is some questions:

1. Im unable to upload firmware from the arduino IDE (and Visual Micro) both via the oilpan FDTI and my own (known to be working FDTI) cables. No Tx,Rx leds starts flashing and avrdude just seem to hang infinitely. I know the MCU is working, I can read fuses etc and even run the software with mission planner (see question 2):

2. Which arduino board to select: Ive tried  'Atmega2560 or Mega ADK', and in desperation some others...

3. Im able to upload software via the MissionPlanner app through the onboard FDTI (oilpan), which indicates that this is not a HW problem? It should work from Arduino IDE also?, furthermore, the serial monitor in Arduino IDE outputs good serial data, Im just unable to upload my own compiled (it compiles @ v2.66 Arduplane) code, very wierd. Ive done this successfully before with Apm2.5 hw.

4. What does the switch beside the DIP switches do?

5. After uploading the 2.68 ArduPlane firmware (via MissionPlanner), Im able to boot the ardupilot and it initializes then start sending Mavlink messages over the serialport. However there is no changes in accel values ir gyro (yaw, pitch, roll). I understand that the oilpan can be completely messed up But im asking if there is something that I need to do which is apm v1.4 specific inorder to get gyro and accel running?.

6. Since the dataflash is broken (for now), In what ways can this affect the system overall, isnt it just needed for the realtime logging?.

I really want to be able to upload my code, then I could start writing diagnotstic code and test the HW.

Any feedback to any of the many questions above is welcome!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Monologue Update: Stayed up all night and found this solution to problem #1: https://code.google.com/p/arduino/issues/detail?id=806

    Now it works after swapping out avrdude.conf and exe with version from arduino-0022. Something todo with reset timings...

    I was previously using arduino-1.0.1 version. This issue was apparently fixed in arduino-1.0.2 also, duh! should have just tried downloading the latest right away...

    Going after gyro issue #5.

This reply was deleted.