Hi folks,

1st post and 1st time using the APM 2.5.2. I couldn't find this searching the boards.

I'm using the standing turnigy type remote in mode 2. I've plugged in the signal cables from the receiver to the APM and are attempting to do the radio calibration. What I find is it reads channels 1-3 but reads nothing for channel 4 (yaw). When I take the lead plugged into channel 4 and plug it into channel 7 and redo the calibration it reads a signal.

So I have a signal coming from the radio receiver, but channel 4 input on the APM wont register it receives it. Any tips? I'm worried it's a hardware issue. The soldering on the bottom of the board looks top notch. Do you feel it could be a soldering issue? I'm a little hesitant to apply some heat and cook the board. Then again I've disabled the on-board compass so I guess it's hard to return it.

Any help is appreciated.

Views: 187

Reply to This

Replies to This Discussion

Is it possible for me to change the input assignment so the Yaw signal is read from say input 7? I can't see a way to do it but that would get me around the issue

Okay I've tried to resolder the pin twice and had no luck. I have no idea what it could be. I've also updated the firmware to the latest and I get absolutely no signal reading in channel 4 input. Still works perfectly on the channel 7 input.

I'm lost folks. Need help

Or is there some way internally I can push the signal from say input 7 to input 4? 

I know this is an old post but I'm having the same problem. I have the V2.4.1 board. Were you able to get yours fixed?

Yes I just mapped one of the other inputs to the channel 4. It's been a long time since I did it so I can't tell you how to do it. But I know I found a way on the apm board to map one of the other unused inputs (5-8) to chanel 4. Trying to fix the input pin never worked.

Good luck

Thanks so much for the reply. I had thought of doing that but was not sure if it would work so that is great to hear! Since you have the same problem I'm guessing its a hardware issue. If you happen to remember the firmware version you modified or have the hex file handy that would be much appreciated. I noticed in addition to IN4 (yaw), IN5 and IN6 don't work either. but IN7 and IN8 work so I could use one of them. I'll see if I can edit the code.

Sorry I don't have that with me. From memory you don't need to edit the code. But you need to do it in the advanced settings area. It's a page in the mission planner that lists all the parameters. I'm fairly sure that's how I did it. It's just been a long time.

That is great news. That should save me a lot of trouble. Thanks for the reply.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service