APM2.5 and XBee not working

Hi all,

For some reason I just cannot get any data from my APM2.5 via xbee. Never had any troubles with APM2.

I am connected to the "new wireless port" on APM2.5 via a UartSBee breakout.  The two XBee's connect to each other, no problem, however I am receiving zero data from APM.  I have scoped the line and it is sending but the TX LED (or RX) is not flashing.  I have also tried using a XbeeExplorer breakout, here the LED flashes saying APM is sending out, however nothing is coming through XBee to the GCS (or hyperterminal).

I have tried the usual things of TX&RX being the wrong way around to no avail, and also a different XBee module. Works fine when I USB both of them to a computer on the same breakout boards.

I'm quite puzzled by this. My only possible thinking is that the logic level is not high enough to register as a "1", but I thought APM was 5v and Xbee 3v3 so surely there shouldn't be a problem through the level shifts on the breakout?

I'm currently using the AutoMUX UART0 port on APM2.5, will try switching to UART3 tomorrow but I'm doubtful this will work after scoping the line & seeing the data flowing fine.

Anyone else had similar problems with APM2.5? Any solutions or suggestions?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Interesting points raised, thank you all.

    I think the heart of the problem has now been identified that the APM2.5 does not have the power in the IO line to drive the XBee (meaning that the setup guide is wrong, or at least misleading, and should be updated for clarity).

    A solution is to use the new explorer board which has MOSFET level shifts on it (I've personally not tried this though), or use a different radio.

  • I have tried enabling UART2 in the code, and soldering the jumpers on the reverse of the board.  Still the same problem.

    UART is sending out but nothing is being sent over XBee.

    Interestingly if I send data from the PC to the APM Xbee, the RSSI lights up as expected, the transmitting XBee RX flashes but the receiving XBee (and the APM) TX/RX does NOT flash at all.

    I'm thinking this may be the XBee breakout being the weak link, but I have no idea why?


This reply was deleted.