I was playing with my Hexacopter yesterday and running a 20 waypoint mow-the-lawn type mission photographing a field just to learn how.  Two successful passes worked just fine.  At the end due to a mistake I made, I switched into Stabilize from RTL without enough throttle and the machine dropped about 6 feet onto the ground.  I would call it a solid thump, not a real crash.  After straightening out landing gear etc, it was flying just fine again.  Except.....Auto mode was very flakey.

Loiter, RTl all worked fine.  Auto caused the machine to lurch the wrong way and descend at an angle, more like a plane trying to land very steeply.  I tried it a bunch of times and the behaviour was the same.

When I got home, I hooked it up to the laptop, and for some reason there were two new mission steps at the beginning.  Step 1 was now a LAND command and Step 2 was now a TAKEOFF command, in that order..  They were not something I programmed.  All the other waypoints were there, now shoved down by two rows.  The behaviour was certainly like a really poor executed landing, I never let it finish but it would have landed like a STOL plane.

I checked my .kmz files and looked through my log files and nothing looks abnormal, just Auto mode engaging as commanded.  I can post logs if that helps but I cannot figure out anything abnormal.  How did it reprogram itself?

I notice sometimes when I clear out a mission, occasionally two steps appear like a default, I never pay to much attention to them but I think they are Takeoff and then Land in that order, the opposite I saw above.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I figured it out.  My channel 7 was set to the default for setting way points.  However I was using channel 7 for camera tilt.  When I tilted the camera all the way down (not the channel end point), and I also turned the copter completely over, it saved 2 way points.  I am not sure why but it saved the same Land and Take Off commands as opposed to an actual way point.

  • Does anyone have a wiki link to the use of channel 7, I know I have seen it at one time.

  • Yes, I can also confirm this behavior (although in my case ch7 is set to RTL).

  • I have had the mission add waypoints for no good reason in the past - the fix is to disable ch7  'Save waypoint' function.  Once I did this I have never had a goofy waypoint appear.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21