APM2.5 Setup issue with GPS.

Hello, I started today with Arducopter using the APM2.5 and the GPS UBLOX by Crius, before I used Multiwii the ArtuPiratesNG.

The APLM 2.5 power supply is from PWM input, I using the power supply from my receiver, it is preset in PPM mode (FrSky FASST for a T9Z).

I updated the APM2.5 successfully with the last firmware  through the Arducopter Ground Station, then I done the Level Calibration and the MAG calibration procedure.

So, all worked very well (on the bench) till I connected the GPS.

When the GPS goes in FIX 3D the artificial horizon starts to move seldom, slightly but it is moving, like moving by hand the APM board, if I disconnect the GPS the board do the correct job.

This is a strange behavior.

I need to solve this issue before to proceed to start with flying tests.

I hope this could be solved easily, and I appeciate any suggestions.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


This reply was deleted.