APM2 Crash

I lost my Mentor to a crash tonight, which is disappointing because it's my first crash. I wouldn't be so disappointed, but I don't know what even caused it. I'm hoping someone can shed some light.

Here's my set-up.

Multiplex Mentor

Futaba 6EX 2.4gHz radio set.

APM2 running 2.50

3dr 433 Telemetry

External MediaTek GPS

Lipo 4000mAh 3S

Had been flying for quite a while, and was on the last flight of the last battery. (plenty of charge left though, 11.6 volts right before I took off. Anyway, rest of the flights had gone great. I had finally gotten the PIDs dialed in so FBW-A worked flawlessly. Even ran a couple rectangular patterns in Auto. Navigation needed some tuning, but that is a different subject.

So I take off in stabilize switch to FBW and one tight climbing right turn and then a gradual climbing right turn and all of a sudden I get an uncontrollable pitch down, and since I was still climbing at a high power it shot toward the ground quite quick. Tried to switch back to stabilize mode, but I think I was too late. 

Data log exists up until just before impact. Funny thing is that it shows pitch up the entire decent, when I know for a fact that it was nose down during the whole incident. Hit the ground at 28 m/s. Destroy the fuselage of the plane, but all electronics survived. Servos and APM seem to function normally after hooked the back up on the bench. APM shows correct pitch and roll. 

Did my APM lock up or will I never know what happened?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Check your logs again and see if you lost GPS lock before the dive. There is a bug in 2.50 where AHRS gets screwed up if GPS is lost.

    One other thing and you are not the only one who has done this, why don't you switch to manual and pull out of the dive. If the AHRS is messed up, it's messed up in all modes that use it. At this point only manual control will save you.

  • Further investigation make me believe that since I was in FBW-A, the APM somehow got confused and thought it was holding max pitch up, while in reality, it was pitched down. But since it thought it was at the max pitch, it couldn't do anything to arrest the descent. Elevator input and output confirms that I have full up elevator on the controls, but the APM was commanding neutral. I know I flipped the switch to go back to stabilize, but I'm not confident that I did it in time. Telemetry showed FBW through the crash, so I'm not sure if it didn't respond, or I just flipped it as it hit the ground.

    Anyone have any idea what would cause it to sudden lose track of it's pitch? Works fine now on the bench.

  • The tight turn probably caused a centrifugal force that caused the pitch to read wrong.  The APM uses only basic corrections for centripetal forces in the AHRS.

    You probably shouldn't do tight turns until there's an advanced AHRS system in place.

  • Oo nooooo,im still waiting on my 2.5unit
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
yesterday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…