Hi,Ok im looking for some help here...I hope this is useful to others also as this wasnt obvious to me until this evening, stange things are afoot!...Ok the scenario..UAV1 - Running 2.4UAV2 - Running 2.3.1After a full day of testing ( well at least mucking about trying to get flights in between hicups)Flew missions on U1 with 2.4 sorted the throttle issue (see other thread) but it would not track to waypoints..2 Main flights taken results,,,1st flight set up my usual 3 wp's as the tester...took off...got to 150 feet, turned on AP....the fun began...with AP on, it started a fairly tight turn onto target....all looking good....then cruised...kept good altitude, but kept over shooting wp (was very windy above 100') it tried to get to wp1 several times but missed it, then went on one of it sight seeing tours, then tried again..didnt make it..Landed it, set the wp radius in config to doube the amount around 120, still the same problem.....wandering all over the sky but not hitting way points, again on one of its sight seeing tours to get back to wp1 i let it go downwind a little too far, by this i mean i screwed up big time....it shot off downwind about 1000 feet (the worng way) lost loads of height down to 75 feet....it then dissapeared...OMG....its gone, after about 30 secs it re-appeard coming back to us, which was very good as i had no radio control over it all and the contents of the airframe had more investment , than money or reputation can buy, telemetry was saying it was still flying but that was the only sign of life...Getting back to the point, I have changed the 406 for a Locosys, the PID as not over controlling but direct, but still refuses to track onto a target...PART 2:After our massive scare, i decided to use a cheap slightly smaller copy of U1, just incase we lost it, so in seting up U2, i decided to use 2.3.1, same settings, tracked onto target almost right, (bit more tuning required) but it worked, so went back to 2.4, just to prove teh point, sane problems again, OK must be a knackered board....swapped Ap`s over, no difference...sames problems...swapped shields, just in case, no difference...Now the weirdest things of all, connect up U1 with 2.4, gps lock fairly quickly , solid blue light, pull teh pin, GS reading everything, on U2 (2.3.1) same quick lock, pull the pin, GS sees nothing for up to 2 mins...data is coming out but no long lat or attitude, at line 120ish on ardu serial monitor we get another long lat then nothing all reading lon-1,lat-1,, alt65535 , finally everything comes alive, GS reading everythign,So why?I really want to use 2.3.1, as the tracking is much better for me, but the setup time, is huge, i never noticed as , as soon as teh light goes solid blue i launch, may bethere is another problem going on here i have no understanding of, has anyone got any thoughts, experienced this?I would not have noticed unless i looked on ardu monitor.Jordi, you are the code guru, can you explain please, as im scuppered at the mo, cant move forward untill we can understand if this behaviour is normal, both the speed at startup with 2.3.1, and or the watpoint missing 2.4?Also hwo do i check if the Locosys IS def runnning at 4hz...all bit confused...Looking forward to everyones thoughts.regards,MIke

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Dr. Mike, I think I may know you problem. Its not the firmware version as the gps part didn't change. I saw the same behavior as you are seeing and it was because of a corrupted/fried? 406 that was sending out garbage data, but still sending.
    I have found a small bugaboo in the gps part that controls the blue led. If you never get a valid checksum after the blue is on the part that turns off the blue led never happens. I have a U_blox now and it doesn't have this prob. Its like the gps can just die and it can't tell the blue led to turn off. Also the lat/lon will just freeze as is when this happens. Check your wiring. Could be cause by engine vibration & cracked solder joint?
  • Anyone??????
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: To get ground truth I measured the rug, found the pixel coordinates of its corners, calibrated my phone camera with my standard…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: @DIYRobocars is back in December, but outside. Time to reinvestigate ConeSLAM! I rigged up a quick and dirty ground-truth captur…
Nov 5
More…