Developer

Arducopter 2.0.42

Just posted this version which has an increased performance DCM implementation. This allows the main loop to run 50Hz faster without increasing the CPU load. I've flown this for 30 minutes and it's an improvement in every respect.

 

Circle mode now seems to be working just fine. This should be the last beta! enjoy testing!

Jason

 

 

Here is the Link to a download:

http://code.google.com/p/arducopter/downloads/list

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I just upgraded to 0.46Beta, but I'm unsuccessful at turning on the battery monitor anymore.  Is the IMU battery monitor no longer supported?  Btw, I've flown it once, and initial impression is that it seemed more stable than 0.40.

  • Did anyone else lose pitch on camera stabilization when using 2.0.42?  I was running 2.0.37 and both the roll and pitch worked well.  But as soon as I switched to 2.0.42, the roll worked but the pitch didn't. Anyone else?  Any solutions to that?

  • I just flashed the new .42 beta with the planer tool.

     

    I went outside for a testrun. I waited for a gps lock and startet my quad up in the air. It flew perfectly.

     

    Then I tried Alt-Hold. (Yesterday I put some bandage on top of it to prevent light and air flow to reach the sensor). It stayed within +-0,5m. Very good!

     

    Then I tried LOITER: This was very strange. The copter went up and to the left-front side. I tried several times, it never did hold position.

     

    Later I tried CIRCLE: The copter started moving for like half a C, then dropped to the floor. I was so supprised that I wasn't able to switch of throttle before the crash. Because of that I broke a prop (APC) and have to change it later.

     

    I don't have any logs, because I don't know exactly how to use them.

    Or does the copter log by default?

     

    5,8Ghz video transmitter and the 2,4Ghz xbee are sitting right next to the gps.

  • Developer

     

    I still have a mode problem with ACM 2.0.42 and Mission Planner 1.0.75.

     

    I've enabled the Mission Planner mavlink console, and here is what i get :

     

    when i put "Auto" on my transmiter, i get "Alt_hold" in the mavlink console

     

    when i put "RTL" on my transmiter, i get "Loiter" in the mavlink console

     

    Same wrong modes in the CLI.

     

    If i correct modes in the CLI or Mission Planner, the changes are lost after reboot.

     

    Modes were OK with previous versions.

  • Moderator

    right on :) thanks for the heads up all the same :)

  • 2.0.42 is best software that I flew.over ardu-NG . https://www.youtube.com/watch?v=MafOpaPMlls 

  • Well guys here are is my 5th flight, this time indoors, wind free :) With no previous experience in air RC I'm still trying to get skilled enough to try the auto modes. 1st video in simple mode, 2nd one in stabilize ! After all the frustrations in the process of having it finally in the air, that's a big reward and I'm hooked, batteries should last forever ehehehe I would like to thank both the developpers and "colleague aviators" :) This is a great project in every ways.

     

  • Morning,

     

    So I got two more flights in today, 3 in total.  1st flight alt hold behaved as it should, this was in the morning.  2nd Flight Alt hold diverted to how it was a few versions back... up down hit the ground up up up down down.. This was is the blazing sun.  About 30C.  3rd Flight alt hold as pretty as a peach... worked wonders, flight in the afternoon.  Same area of ground for all three flights.  The pavement I flew over is made of stone.  Test all 3 flights over grass too with no change in effect.  All flights low level about 1M using sonar.

     

    Regards,

    Solo.

  • Just thought I'd give a quick comment on the new 42. I've just uploaded it to my octo (full droidworx setup with pro cam mount) simply replace the quad line of code in Arduino 22 and that's it. It's SUPER smooth, went out for a short test flight in a fairly strong head wind, and it was rock solid, no nothing, just sitting there, I must admit the previous version 39 I think it was that I was running was also very good, this new version just feels more 'refined' it's great and hopefully reliable.

     

    Thanks again!

    Duran

  • Jason:

     

    I have been flying .42 for several days with very good results in STABILIZE and ALT HOLD.  For the past two days I have been testing ALT HOLD and LOITER with favorable results with the exception that in LOITER the Quad decided to decend slowly and they I took control back.  I noticed that the forward and backward controls seemed to deminish in their full joystick response.  I was  able to land but it was not easy.

    I want to test way points but based on the current feedback I am not sure that is a wise thing to do.  My quad is the standard jDrones unit with all the gadgets except sonar.

     

    I have my Hexa ready to go as well but that is way too many $$ to use as a test bed so I am staying with the quad for now.  What do you recommend?  Is it safe to fly single way points?  Based on the latest replies it appears that the software wants to land the copter at the end of the time period for any given way poinit.  Is this accurate and if so, what is the fix?

     

    Allen

     

    Allen

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…