Arducopter 2.0.43

I pushed 2.0.43 to Git.

What's new - Simple mode is dead. It's now an option per switch position. There is an APVar bitmask called simple_modes or "SIMPLE". Setting any bits 0 - 5 to 1 will cause that switch position to access simple mode. You can also do this with radio channel 7 if you compile for it. 
Until the mission planner is updated, you can use the CLI by using the rudder as an on/off swicth in setup::modes. It's very easy.
There are now two battery values to set, input_voltage ("IN_VOLT"), and low_voltage("LOW_VOLT"). These are for folks editing battery information.
Circle mode is now tested and running well. It's very cool, but requires dialed in Loiter PIs.
Guided mode is not tested but should work just fine.
Lot's of other minor tweaks and code cleanup.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Jason,


    One quick question for you.

    Just finished building my OCTA V with 8 ESC-s paired in 4 Y setup (2 ESCs in pair for each of the quads arms), that I planned on flying like a X QUAD... Then 2 days ago I stumbled upon this information, that I can connect all 8 motors to separate outputs, that I suppose gives us better (smoother) corrections of attitude. So I cut all the ESC signal wires from distribution board and connected them directly to APM outputs as per this scheme below.

    Then I installed new Mission Planer, and wanted to upload new firmware, when I realized that there is no option to select OCTA V frame in it.

    Now the question... Which firmware to upload, and do I need to reprogram something for APM to start sending signal to outputs 10 and 11.

    Thank you


  • Not sure is this was mentioned before but just to get some clarification as I tried guided mode today:


    Altitude: As sson as I switched to guided mode it started to accent. I read in the wiki that the behavior is similar to RTL so, is that because my RTL height was set relatively high? I guess I could try to set ALT_HOME = 0 to stay at my current height?


    Attitude: I noticed that the copter does turn for some degrees. I am not sure if it is pointing towards home or the next waypoint. If I look at my config I see yaw_mode is set to YAW_AUTO which should have it look toward the next WP.


    Is there other parameter I need to adjust to get the heading correct?





  • Look how well performs new fw in Alt_hold and LOITER:



  • Not sure if anyone else already mentioned this.  In the latest code from Git:



     /* CH7_DO_NOTHING




     CH7_RTL */


    In the Manual:

    To use Channel 7, you must upload with Arduino and add this line to APM_Config.h:



    I'll figure out which one it is, but wanted to point out the inconsistency.




  • AUTO TEST(...continue)


    More test done this afternoon. I came back to 2.0.42 since 43 with APM 1280 gave me some extrange things (see my previous reply). Defaults PIDs


    I used also the same copter but I changed to APM 2560 (last succesful AUTO tests).


    Now things whent back to normality: very good stabilize, loiter, RTL and ALT_Hold. SIMPLE worked as allways.

    AUTO path: Takeoff, WP1,WP2,land

    Some problems detected:

    1. Firs try in AUTO: started well Takeoff and WP1 then lift to the skies for WP2. I repeated 10+ times and always the same. After reviewing the path in MP 1.0.73 I notice it readed for WP2 Alt=300. I wrotte again default Atl = 3, WP2 Alt=3 and clicked "write". I "read" again and is found again 300. ¡ITS A BUG IN THE MP 1.0.73!. Always "read" the plan after "writting" to check. So, the fly in AUTO worked well aparently (but very high! trying to reach 300m )
    2. Comparing behaviour of 2.0.42 and 2.0.43 is totally different (good in 2.0.42, bad in 43). It can be either the APM 1280 under 43 or the firmware itself (I guess is the APM1280). I´ll try to load the fw.42 in APM1280 to verify this.
    3. Modes done with the configurator of APM are incorrect for fw.42 (is prepared for new fw.43). Use the CLI better.



  • Jose thanks for the reminder, actually the crash I had (with the gopro onboard only) was testing RTL and everything went smoothly but it was off by 10-12meters then got close to the tree. I switch to stab (so i thought) but was actually SIMPLE mode that caused the crash :D Pilot error.. I didnt lookout for the tree and I didnt looked at my ardustation to check what mode I was on.

  • Thanks Davey...


    I was gonna put your name Jose but wasnt that sure...well putting up the cam mount now but realize I need a proper way to connect this to my quad so I might be delayed a bit more....but cant wait to test it. I like the yaw on a waypoint that Jason mentioned...

  • I envy you guys I havent been able to test v43 as my copter needing repair but finally got the cam mount replacement today so I think I should be able to join you soon. I am most interested in testing nav_way points as in all previous test I only got up until CIRCLE due to lack of space. I am a bit unfamiliar with the flight plan on mission planner specially the height. I remember someone got some very close encounter (with the ground) due to height @ HOME so it even made me more hesitant. I dont have laptop on the field to configure the waypoints so I can only preload it from home. Any pointers I should look out for?

  • Jason, is the code in git right now compilable?

    ArduCopter.cpp: In function 'void roll_flip()':Attitude:87: error: too many arguments to function 'int get_stabilize_yaw(long int)'flip:48: error: at this point in fileflip:62: error: 'get_throttle' was not declared in this scopeflip:75: error: 'get_throttle' was not declared in this scopeheli:4: error: 'get_throttle' was not declared in this scopeheli:13: error: 'get_throttle' was not declared in this scope


    Or is it my fault?

  • AUTO test in 2.0.43

    After succesfull AUTO test in 2.0.42 I´ve tried yesterday with 43 but in a different copter: a bit higher and powerfull (about 1Kg) and ussing APM 1280 (instead of APM2560 in a 650g copter). I had several issues:

    1. After first arming: GPS and RTL didn´t worked well (they went to wrong sites). Then I´ve armed again and repeated the problem. Then switch off and on and then, it worked well. This log was wrong (I couldn´t download, it says "wrong GPS coordenate values")
    2. LOITER didn´t worked well (spiral divergence, like old versions). Maybe some PID tunnings are needed, but strange. There was not too much wind, only some random gusts. I repeated many times LOITER with same result.
    3. SIMPLE didn´t work. I selected a mode with STABILIZE & SIMPLE=ON and it worked as stabilize only, not simple.
    4. AUTO. It did the work but not very well: it was shifted 20m about from what is expected (gps bad signal?). The worst think is when landing did it with some lateral speed, ending with a small crash. I repeated 3-4 times, and always did the same. Could be the APM model the reason?.
    5. I couldn´t download any log. Some was corrupted, the rest were empty.

    I´ll repeat same tests with my other copter (APM2560) to compare behaviour.




This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21