ArduCopter 2.7 Released!


In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:


New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc


  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc


No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have 2.7 loaded (did an erase in CLI first). Copter is a quad DJI 450 clone frame, DJI motors and 10" props. Stock Hobbywing Skywalker 20A esc's, 3000mAh Hobby King Nanotech Battery, 3DR telemetry radios, Sonar, External UBEC, Futaba 7C radio and R617FS receiver.

    I have set flight mode 1 and 2 as Stabilize. 1 should be "Simple Mode" as well.

    My issue is both act as Simple Mode even if the check box in the planner (1.2 mav 1.0) is unchecked.

    The parameter list in the planner shows Simple as "0".

    No matter what I have done so far upon liftoff the quad orients itself with the direction it is facing when "Armed".

    All tuning parameters are "stock".

    I have only tried it indoors in Flight Mode "Stabilize" since loading 2.7 yesterday.


  • I have a short question on stick and gyro zero position calibration:

    I understand the roll/pitch/yaw receiver signals are sampled sometime during initialization (or is it after arming)  and used as the zero point during flight.  Is that true?  If so, when is it done?

    Likewise, I know the gyros are sampled to provide a zero reference at some point in time.  When does that happen?  Is it during arming?

    I had a minor mishap where the quad flipped forward (very gently...) on takeoff.  I have a feeling that this has to do maybe with moving at the time the gyros were calibrated, or maybe something with the receiver calibration.


  • Hello,

    Someone has the same problem as me?

    I uploaded version 2.7, do a erase + reset and delete logs. I even tried to upload the v2.5.5 and then 2.7. But I have the same problem with the engine management, on startup, only motors ccw work, then more power with the four engines operate and the quad starts to fly. but all of a sudden the engine cuts out.
    I went back to 2.6 and no worries. tests were carried out on my 2 APM1

  • Ok can someone please tell me if the new 3DR GPS can be plugged into the APM2 and work without removing the GPS that came with the APM2 ???

    Will the board use this one if it plugged into the board or will I have to remove the GPS unit as If this is the case I will lose my logs? Can someone please explain!

  • hi all, 

      Is anyone else having problems downloading there logs? i've tried both apm1 and 2 and on both it's the same, an error message saying " error opening comport".

      Any help much appreciated 

  • I have a question about RTL:

    We tried it today with 2.7, it worked fine, came but home but descended to about 2 meters and did not land.  I found an RTL_LAND on the Planner screen, documented as 0=don't land, 1=land.  Changed it to 1, but it didn't help; still approached at ~ 2 meters but did not land...

    What am I missing?

  • Great work everyone! I'm using stock 3DR/APM2, sonar, xbee and 3300-5000mAh 4S and carbon reinforced 10" props with stock motors. Yesterday I had the courage to take it to 500M and drop the throttle to zero. After hearing it whistling in free fall, I gave a little throttle and like magic it righted itself :) Now to try the flip switch :)

  • T3

    Hi.  Is it safe to use "land" as a flight mode?  Like when I invoke it, will my copter auto land?  If someone would explain the land flight mode it would help me out a lot, the wiki is kind of lacking in this area.

  • Hi all, I have a problem with 2.7.
    to 1/3 of tx throttle begins to accelerate progressively to maximum, it just does not touch the accelerator,
    is like having a command on or something that will only accelerate,
    with no code has happened to me only with the 2.7.
    everything else is perfect GPS signal level orientation etc.
    perfectly balanced, with default pid, only on test bench.
    APM 1.4 850 10x4.5 prop motor sc 10 amp sound frame lv EZ4 XAircraft 650v4

  • Hi all,

    I'm on holiday in Croatia and took my quad with me ;-)

    I've loaded the recent 2.7 and flew a bit.

    It was very good but I felt like 2.6 was smoother for me. ALt hold in 2.7 is great but when I switch to loiter its very twitchy compared to 2.6. I hope this has'nt gotto do with buying a new GPS. Still flying with meditek.

    The rest off the feature testing will be for next week.

    Thx to the dev team for their dedication and free time.

This reply was deleted.