ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I gave 3.2 rc2 a try tonight. So far I love it and the only thing I noticed was Drift mode (my Andropilot on my phone keeps calling it "Toy") seemed really slowed down. Where before the turns were quick (and fun) like bank and yank on a warbird now it seems to handle like an old bus and takes almost the entire field to make a simple turn. I can't even see any banking in the turns. For safety sake I had geofence set and it took so much room to turn it kept hitting the fence and going to RTL. Maybe I still have something set wrong although I pretty much kept the Iris defaults. I was really looking forward to playing with Drift now that Alt_Hold is mixed into it.

    I'll try it again tomorrow weather permitting since we have a thunderstorm moving in.


    • Developer


          Thanks for the report.  A few others have made similar complaints about the slow-response in yaw.  There are some parameters starting with ATC_ (i.e. ATtitude Control) that could be increased and might improve this but basically we need to increase the default rates probably.  We should be able to sort this for -rc3.

      • Thanks for the reply! I tried fiddling around with one of the "ATC_" settings, the one that looked like the most logical one and test flew it a bit. Not sure I had the right one since I couldn't see much if any difference. That's when it hit me that I was only guessing and that I'm probably better off waiting for rc3 before I really mess something up.

        Something else I've noticed and this is something I've seen in earlier versions back to 3.1.2 (what my Iris originally came with?) is the Geofence. I go into MP and enable it but when I go back into MP later, it's disabled. The only time I've had it work when I tested it was when I turned it on with Andropilot. After the flight when I checked it again with MP, it was disabled, I did have it setup on Ch7 switch once but that didn't seem to make any difference once I went back in with MP. Always showed disabled. This might be normal and I'm just not used to it?

  • @Felix, it is better to open here to show  my understanding.

    As you already know a lot on this area, Pixhawk consists from PX4FMU-V2+PX4IO-V2.

    The firmware for PX4IO-V2 that is provides by ArduCopter 3.1.X dose not support THFSS-Air.

    That of ArduCopter 3.2 rc2 support THFSS-Air.

    Both ArduCoter 3.1.X and ArduCopter 3.2 support S-FHSS could handle S-BUS receiver FASST.

    If you want to use telemetry feature with T10J-R3008SB then you need everything.

    1) Bind T10J-R3008SB with THFSS-Air for telemetry

    2) Connect Pixhawk R/C input port and R3008SB S-BUS

    3) Load ArduCopter 3.2 to Pixhawk

    4) Calibrate R/C on Mission Planner

    5) Connect Futaba CAR-VIN-700 external voltage cable to your R3008SB

    That is all.

    I hope the release of ArduCopter 3.2 includes new S-BUS communication feature;)

  • Hi to all

    I had installed the beta firmware yesteday night. I flew tonight with a friend who was handling the remote control.

    F450 - apm2.6 - standard ESC. - compass set in the field, at the time.

    First batery (4500mA) - stab - loiter - alt hold - auto (4 wp): perfect, ultra stable but we had 0 wind - open field, blue sky.

    Second batery (4500 mA)- stab - loiter - alt hold, land (2 or 3 times), guided : perfect, ultra stable 

    Third batery - start en auto : perfect - WP : perfect - back to loiter.

    HERE : I was  playing with my droidplanner, trying to set Hybrid. 2 or 3 times. Droidplanner stay in Loiter. Nothing happen. The drone stay stable, quiet AND felt. From 10 meter approx. 1 leg broken but nothing more.

    I look at the logs. I do not see anything except Err flight mode 16. Maybe the hydrid syndrom ? 

    Thank you for your feedback.

    2014-05-27 18-06-32.log

    • Developer


          A few things went wrong here I suspect.  The flight code is AC3.1.5-rc2 so I suspect you uploaded it just before AC3.2 went out.  So the vehicle was running the current production code (AC3.1.5-rc2 is the same as AC3.1.5).

          I think you switched into Hybrid mode from droid planner (which explains how you could do this without it being setup on the channel 5 switch).  These attempts to switch into Hybrid correctly show up as errors in the logs but these don't cause the copter to crash.  The attempts to switch into unsupported flight modes is just ignored.

          As for the crash, my guess is that the battery wasn't charged properly.  At the end of the logs the throttle goes to full but the vehicle falls.  The throttle later goes to zero but this is after the vehicle has flipped over and is on the ground.

      3702495223?profile=original     I looked at the CURR message in the logs which will show the battery voltage if you're using a power moodule (or Attopilot sensor) and although it has numbers they look like noise.  I.e. the voltage monitor isn't working.  A working voltage monitor will start off at maybe 12v but as soon as power is applies it will drop by 1V or more.  In this graph though the voltage just jumps up and down somewhat randomly.


      • Thank you Randy for you time and analyse.

        For this quad, I am using an ESC to get 5v and using A1 as input voltage. Well, this is not the best way I know but so far, it was working.

        About bateries, I had fully charged the 3 (4500Mah) - We used the first 2 for 10 min and the last less time.

        The fact is that I wasnt watching the drone (it was flying so good !) when it fall and the pilot was not very experienced to remember what happened.

        Anyway, you are doing a wonderfull job 

    • Hi Max,

      From your params, none of your 6 Flight modes is set to hybrid.

      You have:

      Flt_Mode 1 = Stab

      Flt_Mode 2 = Loiter

      Flt_Mode 3 = Circle

      Flt_Mode 4 = Alt Hold

      Flt_Mode 5 = Auto

      Flt_Mode 6 = RTL

      You should assign one of them to Hybrid maybe...

      • Hello Julien

        I know that. But I do not know if there is a relation between Droidplanner (trying hydrid from here) and the fact that the drone fall like a rock. Anyway, I put the new firmware, program hybrid on my RC and see...


This reply was deleted.