ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • that's totally new, for now I know when you upload new 3.2rc3 pix is asking you to calibrate compass again so it uses internal one as well....

      Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) should re-do their accelerometer calibration because AC3.2 also uses the backup accelerometers on the board (which may be uncalibrated).  A pre-arm check will be added to -rc3.

      would be nice if double gps already working so we can use expensive 3dr gps together with less expensive and superior new gps ublox 8....

      • Developer


             You should be able to plug in the Ublox7 and Ublox8 to AC3.2.  I hear good things about the Ublox8 but I can't give any guarantees.  The Dual GPS is also a nice way to make use of those non-compass Ublox that you may have hanging around.

            Yes, the need to recalibrate the compass is a bit of a drag but it was unavoidable.  The changes make sure that the internal compass is calibrated so it's ready in case the external one fails and it also checks that the vehicle's compasses haven't changed since the calibration was done.  It can only check the the type of compass (and the number attached) but still it will catch if you disconnect the external compass (or if it fails) between flights.

             The pre-arm check mentioned in warning #1 has been added now.

             Warnings #2 and #3 have also been resolved now so I'll remove those from the discussion above.

  • Hello devteam,

    First of all let me congratulate you on your awesome FW.
    It's getting better all the time.
    But......I wanted to try the V3.2-rc2 version on my quadcopter with a PixHawk FC (with ext compass), and noticed a very strong drift forward.
    On my Taranis i had to pull back my pitch stick about 20% to keep it level.
    I callibrated everything all over as if it was a total new firmware, without any result.
    When i flash back to the V3.1.5 it's flying like a charm. Without any re-calibrating.
    Is this a bug not discovered yet, because i could'nt find anything on the net? (yet)
    Or is it solved in the V3.2-rc3?
    I flashed both versions with Missionplanner 1.3.7.

    I hope you can use the logs i've included to get some clearing in my issue.

    Best regards,
    Paul La Fors
    The Netherlands

    Logs V3.2_rc2.rar

    • I saw this issue as well, but only when I put the craft into AltHold (for autotuning). After tuning it was fine.

  • Hi Devs,

    Testing 3.2rc3 I can't manage to arm the quad because of "PreArm: Compass not calibrated" showing up in MP (v1.3.7).

    I ran the manual calibration several times, but to no avail.

    I have a PX4 FMU+IO flying really perfect on 3.1.2

    Quad, X, external compass, no power module, 3dr radio, 3dr lea6 gps.

    What I did:

    - start with 'blank' compass params for all compasses (see paramfile 32rc3-compass-initial.param)

    - run compass calibration from MP. It shows me two compasses. The process finishes like expected, telling me the values (for 1 compass only) and storing it.

    - It stored values for two compasses (see paramfile 32rc3-compass-after-calib.param)

    - trying to arm, PX4 still rejects with the 'NoNo' sound, MP shows again: PreArm: Compass not calibrated

    - I do the compassmot routine. The X-Y view shows no activity, but the numbers in the little window do change.

    - It saved compassmot params for only 1 compass (see 32rc3-compass-after-calib-and-compassmot.param)

    - trying to arm, PX4 rejects with the 'NoNo' sound, MP shows again: PreArm: Compass not calibrated

    - Change pre-arm parameter to -5 in order to disable compass check.

    - Connecting/disconnecting battery several times and rotating quad in between, MP show a correct heading. So it looks like there is something working correctly.

    - Flown it, starting in stab, then gradualy increasing flight-mode complexity. Actually, flies really nice, I tested althold, loiter, rtl, auto with splines, poshold, land. It just works like it's supposed to. Two remarks:

    1 About a few seconds from taking of in auto, the quad started to jerk and wobble, while MP told me the same time about Bad gyro health (so in mid-flight). Switched to stab, the quad got stable and I landed. After disconnecting and connecting battery, I tried the same and the auto route was performed without a flaw.

    2 Switching flightmodes. It happend a few times that while testing flight mode settings while grounded (I always do before any take-off) the mission planner screen (initial setup -> mandatory hardware -> flight modes) showed a change when I hit the switch on the RC, but no text was spoken which it always does in these cases. Trying flightmode stab and althold, I concluded that both reacted like stabilize. Disconnect battery and reconnect solved the issue....

    If needed I can provide the logs of all these.

    My conclusion so far: love it, just a few things to be aware of. Thanks a lot for bringing this system to us!


    • The end is missing from my previous reply

      So, when I change COMPASS_DEV_ID2 back to the value right after compass calibration, all is fine and no pre-arming warnings any more. I guess it's not very convenient to do this after every reboot, so I stick to setting parm ARMING_CHECK to -5.

      • Developer

        I wonder if perhaps you've got an old version of the mission planner.  I'm using the beta version (1.3.7 build 1.1.5307.24027).  Anyway, let's see if other people bump into the same problem.

        • Thanks for your replies Randy. I'm using the same version of MP. Meanwhile I did several reboots and till so far 3 distinctive values are reported for COMPASS_DEV_ID2.

          So let's wait a while for other reports.

          If you need me to do any additional testing in the future, just ask me.

    • More investigations..

      Somewhere further on this thread I read Randy's comment about the software checking the compasses id's in order to detect a changed one. This made me redo the compass calibration dance, but FIRST zero the two compass-id's in the full-parameter-screen and do a reboot. After that reboot I discovered the id's for both compasses were set, but for compass-2 it was set to a value it had never been before. Than after the compass dance the MP reported offsets for TWO compasses where stored and arming went well...

      Compassmot via MP now says "calibration successful", but only COMPASS_MOT_[XYZ] are saved which are the values for the external compass (tested with a magnet), COMPASS_MOT2_[XYZ], remains 0. Don't know if this is like it should..

      What happens next: with every reboot the PX4 seems to read a different ID from compass_2 (different

      COMPASS_DEV_ID2 in Full parameter List)

      Therefore it thinks the compass has been swapped for another one and MP again shows: "Compass not calibrated"

This reply was deleted.


DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @diyrobocars @circuitlaunch And here's the final showdown! Video courtesy of @chr1sa I think I was a little faste…
22 hours ago
DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @armand_dpl @SmallpixelCar @diyrobocars @circuitlaunch I use @foxglovedev Foxglove Studio for my visualization nee…
22 hours ago
DIY Robocars via Twitter
22 hours ago
DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at Races begin around 2:00pm PT
Oct 1
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Oct 1
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11