ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • CPU load going crazy >2500%   in mission planner and APM planner.

    with firmware 3.2rc10 and 3.2rc11, if i disconnect GPS it goes down to around 15-20%

    video on bench

    Hardware : Pixhawk and 3DR GPS v2 nothing else connected

    dataflash from outside test & setup

    2014-10-05 13-43-52.bin

  • Hi,

    This version will be pixhawk modem xbee868 for me? 

    Is Px4flow become active?

    Thank you in advance for your answers,

    • Developer


      The PX4Flow is still not supported in AC3.2.  There is some active development going on so I'm pretty confident that it'll be supported in AC3.3 and it will add real value.

  • Developer

    AC3.2-rc11 is now available through the mission planner’s beta firmware’s link.  The changes are in the ReleaseNotes and also listed below.  Changes from 3.2-rc10

    1) reduce lean on take-off in Auto by resetting horizontal position targets

    2) TradHeli landing check ignores overall throttle output

    3) reduce AHRS bad messages by delaying 20sec after init to allow EKF to settle (Pixhawk only)

    4) Bug fixes:

        a) fix THR_MIN scaling issue that could cause landing-detector to fail to detect landing when ch3 min~max > 1000 pwm

        b) fix Mediatek GPS configuration so update rate is set correctly to 5hz

        c) fix to Condition-Yaw mission command to support relative angles

        d) EKF bug fixes when recovering from GPS glitches (affects only Pixhawks using EKF)


    It’s possible this is the final release candidate.  Personally, my only remaining concerns are:

    1. Is the landing-detector still too strict?
    2. Does it run on APM1?
    3. Is the TradHeli landing-detector change ok?

    Thanks for all your help in testing!

    • Hi Randy,

      Is the relay still supported on the APM1 boards?  I've been following the developments but I haven't actively tried anything since 3.1-rc5 and now when I try to compile I get the attached errors.  I've also attached my own little HOW TO that I've written for myself and a copy of the UserVariables.h & UserCode.pde files that I use.


      HOWTO Firmware.txt

      • Developer


        Yes, the Relay should still be supported on the APM1.  The issue is that there are now up to 4 relays supported so I think in your userhook_mediumLoop you just need to change the call to AP_Relay::on() to AP_Relay(0).  Also I've updated the Relay wiki page and it's got a screen shot of another parameter you'll need to set to specify which pin the relay is using.

This reply was deleted.