Developer

ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • There is a tab in the log window for clearing logs.3701736471?profile=original

    • Hi Masam, i am using the "latest" AC 3.2-rc1.  So far, it's handling the copter nice.  However, when i tried to download the Data Flash Log via Mavlink, it says "Timeout on read - Get Log" and the signal strength of the Mavlink as shown on the HUD goes from 100% down to 4%. Is this an issue with the MP or the firmware slowing down the telemetry data? Thanks...

      • I too am having exactly the same problem. The radios are 20 cms apart and the "Timeout on read - Get Log" error message pops up and signal drops straight to < 20% ( random ) and continues to go down and then takes a good 2-3 minutes to ramp up to 95%-98% - Never 100%.

        I have also noticed very frequent drops i.e. No Data received whilst quad is in air and within 30-40 meters of GCS telemetry module. 

        I have tried 3DR ( SiK v1.9 ) radios as well as RCTimer ( SiK v1.7) ones - same problem. So it is not a radio hardware or antenna problem.

        Running AC 3.2.1 and MP 1.3.34

        Does anyone have any clue?

        • Disabled ECC check and downloading log works and no timeouts. But the radio range is still a problem.

    • Thanks so much Masam. 

  • Developer

    AC3.1.5-rc1 has replaced AC3.2 in the Mission Planner's Beta Firmware's link.

    This is just for the next two days while we test this patch release to AC3.1.  Discussion of this patch release are over on the AC3.1 release thread.

    AC3.2-rc2 will be back in the Beta Firmwares link in a couple of days.

    • Lior
      AC3.1.5-rc1 not include hybrid mode. I've tried this afternoon. Waiting for ac3.2. Thanks randy
    • Hi Randy, did you removed hybrid mode on 3.1.5-rc1 ? today I've tried the 3.2-rc1 and I think everything is working and no problem, I tried stibilize, loiter, holdalt is good, and hybrid is perfect, also waypoint with autotakeoff, RTL, Guided and autoland is working well. and then this morning I upgrade to 3.1.5-rc1 and the hybrid mode is gone. I think  AC3.1.5-rc1 is updated from 3.2-rc1

      • Developer

        Yudi,

             Yes, we've had to take a short break from testing AC3.2 so that we can test AC3.1.5-rc1.  AC3.1.5-rc1 is actually a step backwards from AC3.2-rc1.  We have to release a patch to the current official version (AC3.1.4).  AC3.2-rc2 will be back in a couple of days.  Discussion of AC3.1.5-rc1 is over on the AC3.1 release thread.

        • Does 3.1.5 RC1 include Hybrid mode?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…