ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


          • Dido for me tried it today on a galaxy III mini worked fine. It took a few seconds for it to work itself out but then worked fine. 

  • Developer

    I've just tested and updated the sonar/laser range finder wiki pages.  There were errors on nearly all the pages!

    I know there's a complaint or two about weird offsets coming from the sonar, I haven't looked at that yet but will shortly.  It's possible it's related to some of the incorrect info (now fixed).

    • most excellent.....thx

    • Randy, you are a busy guy...  Many thanks!


    • Are there any other flight-controller or mavlink software applications available for these sensors other than the height above ground?

      For example ... is there code to use to follow a distance from a wall and/or ceiling?

      Thank You

      • Developer


        No nothing like that as far as I know.  There are a couple of people working on object avoidance but I can't make any promises immediately about when/if they will come up with something.

  • Just Crash from 30meter altitude. Maybe BrownOut.? i have no idea.

    Appreciate someone take a look my log.

    Hexa Tarot 680, Pixhawk, AC3.2rc10, gimbal sony. bla bla bla..luckily only landing skid and alloy gimbal broken . others part OK.

    Takeoff--> AltH --> Loiter --> Crash.

    after crash , back home, connect Pixhawk via USB failed. but i can connect and download the log via telemetry radio.

    2014-10-01 09-37-55.log

    • Is your pixhawk working properly after that? when you power pixhawk is FMU power led and B/E led working properly?

      If not It seems to be a brownout !
      What bec and what current sensor you use?How have you connected gimbal?

      • - not working when connect via usb, no any led.

        - can connect to MP via telemetry with supply power from lipo . and got some LED. not test to arm because pull all the wire already.

        - not using bec, non 3dr just power module.

        - use alexmos gimbal board seperate 3s lipo. only pitch/yaw controller connected to rc rx.

        - main power connection like this:

           lipo --> Power module --> Power DB  --> ESC

           pixhawk power by Power module --> single wire PPM to rc rx dragonlink

    • Developer


      Nicely spotted by Dan Yeakley.

      I had a look at the logs too and I think it's likely a brownout very likely caused by a sudden decrease/increase in the throttle caused by a glitch on the throttle channel.  This glitching is definitely not good and I'm sure you'll want to try and find the cause but this alone shouldn't cause a brown-out.  There is likely some weak-point in the power system so it cannot deliver the current that the six motors requests.  Maybe it's the power module, maybe it's the battery, it's hard to say.

      What "C" is the battery?


This reply was deleted.


Santiago Perez liked Santiago Perez's profile