ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


          • EFK was / is  off for me too ! see the attached logs

            but strange pulsing sound from motors in alt-hold and pos-hold.

            any help ?


            2014-08-27 19-52-49.log

            • short update !!!! 

              after 27 test flights with different parameters i decided to lower rc_speed from 490 to 400 and the magic "motor noise" problem is gone :-) Video is smooth except very high speed. This time tested with and without EFK.

              hope to get the fix soon for testing !



              • Thanks for feedback.

                Anyways, I see no interest of running >400Hz while the main_loop rate for pixhawk is 400Hz (and only 100Hz for APM) so the motor output would not be changed between 2 different loops.

    • Richard,

      about hybrid (poshold), you can increase the braking rate PSHLD_BRAKE_RATE (default 8°/s)

      I did many tests and 8 was my best compromise but if your copter is very stable and roll/pitch overshoots are very low, you could increase a bit that value (eg: 10-12). The idea was not to get a short and accurate braking (like loiter does) but a smooth one that looks like a manual braking

      Motor pulses are maybe linked to the throttle controller that is tuned too sharply. Try to decrease P (and D) gains a bit. Your TC_Z param should not be too low neither (set it between 3 and 7)

      If you are using a sonar, try to disable it and make other tests.


      • I changed PHLD_BRAKE_RATE to 17 and it still stops very smoothly. My quad is very heavy so the increase seems to work very well for me. I suspect a lighter frame would need much less.

        I will work on the throttle control as you suggest over the weekend. No sonar.

        Thanks for the detailed reply.

        • I reduced PSHLD_BRAKE_RATE to 10...  17 was too high.

  • re compass issue    Log after APM P daily 2.0.15-rc1  Thought for sure it would be fixed because when I re-calibrated the compass ['s] it said both compasses have been calibrated. Did a pixhawk re-boot too. Still a no go unless arm check is 0  

    compass 1 id 2030116352

    compass 2 -1

    maybe I should be posting in APM P as well?


    • Developer

      I've found the issue and it's been fixed in master so it'll all be fine once -rc6 goes out.

      • That's really great. I believe I had the same problem. I have done the Live Calibration Dance atleast 10 times, but it still would complain about Compass Calibration. I also have the 3DR external compass connected to the Pixhawk. (Running 3.2-rc5). Disabled the check in the end, and flew like a charm. Will retest once rc6 is out.

  • Hello Randy

    as you requested on Github i've attached  the logs for the inacurate Autotune issue 1337

    As i was trying today to make new logs, my Hexa went crazy on first takeoff and crashed, don't know why and two Props broken.

    So the files attached are not taken from today's test session but they are reliable not older then some weeks.

    File "2014-08-03 18-31-56_315" is with Autotune in ArduCopter 3.1.5. The determined PID's  worked very good.

    File "2014-08-24 20-31-55_32rc5" is with Autotune in ArduCopter 3.2. rc5 . The determined PID's are not working so good.

    for all other below the origin message for this issue

    Hello @all,
    i've updated my hexa from AC3.1.5 to AC3.2 rc5 and reset all settings to default (setup>reset). After calibration and all the other startup stuff i went out for autotune. unfortunately im getting complete different PID values compared to AC3.1.5

    This are autotune PID values for AC3.1.5 working very well!
    STB Roll 11.25
    STB Pitch 11.25
    Rate Roll P 0.0875; I 0.0875; D 0.0110
    Rate PItch P 0.045; I 0.0450; D 0.0105

    This are autotune PID values for AC3.2 RC5 working Bad!
    STB Roll 5.29
    STB Pitch 5.29
    Rate Roll P 0.0350; I 0.0350; D 0.0020
    Rate PItch P 0.070; I 0.0700; D 0.0130

    if more informations are needed to solve this one please let me know...

    GitHub is where ALL builds software.
This reply was deleted.


DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13