ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Good news, seems that 3DR will replace my Pixhawk for good. :)

  • Be aware in your testing that is predicting "confidence is building that Earth's magnetic field will receive a double-blow from a pair of CMEs on Sept. 12th" . You may not want to fly your favorite copter until it's over.

    • I think I noticed the effects. I had a decent sat count but it was doing strange things in pos hold. 

  • Developer

    AC3.2-rc9 is now available through the Mission Planner’s Beta Firmwares link.  We skipped -rc8 because just as it was going out, Tridge found and fixed a bug in the FRAM (see last item on the list).


    Changes from 3.2-rc7

    1) EKF reduced ripple to resolve copter motor pulsing (only affects people who have set AHRS_EKF_USE to “1”)

    2) Default Param changes:

        a) AltHold Rate P reduced from 6 to 5

        b) AltHold Accel P reduced from 0.75 to 0.5, I from 1.5 to 1.0

        c) EKF check threshold increased from 0.6 to 0.8 to reduce false positives

    3) sensor health flags sent to GCS only after initialisation to remove false alerts

    4) suppress bad terrain data alerts

    5) PX4 dataflash RAM useage reduced to 8k so it works again

    6) FRAM bug fix that could stop Mission or Parameter changes from being saved (Pixhawk, VRBrain only)

    #2's lower AltHold gains may reduce the motor pulsing some APM2 users are seeing but if not we may need to add additional filtering.


    This release does not included the fix to enable reset-yaw-to-armed-heading because it needs some more dev testing.

    Thanks for all the testing people on this thread are doing!!

    Copter: enable auto yaw control in most flight modes · rmackay9/rmackay9-ardupilot@fbf0698
    Added support in Stabilize, AltHold, AutoTune, Guided-Takeoff, Land, Loiter, OF_Loiter, PosHold, RTL-Descent, RTL-Land,
    • Randy,

      If you get a chance can you please take a look at the log I have attached. I loaded rc9 onto my Disco tonight when I got home from work so I could test it. After I flashed it I confirmed all of my settings were still good and also enabled ekf. Took it outside and tried to arm it and it wouldn't arm. Came in and hooked to the pc and it displayed bad ahrs. So I disabled ekf and it seemed alright. So I put ekf on my channel 7 switch.

      Went outside and had a good flight and wanted to check the video footage to do some more gimbal tuning. Did some tuning on that and went back out. Took off in stabilize and enabled ekf and everything seemed fine. I switched to poshold and started climbing straight up. I noticed it seemed like it was oscillating so I quit climbing and starting coming back down. About half way down I switched ekf off. As soon as I did it started flopping forward and dancing around. I managed to hit stabilize just before it hit the ground. Somehow though I got lucky and it landed surprisingly soft on it's feet. 

      The other thing I have noticed is it seems like yaw hunts around a little bit ever since rc7 and rc9. I don't know if it is related or not.

      2014-09-11 19-16-31.log
      • I just noticed something else and I don't know if it has anything to do with the issue. When I flashed from rc7 to rc9, after the flash it plays the musical tones. The tones sounded just like it does when booting up. I flashed back to 3.1.5 and the musical tones were completely different and the normal ones that I am used to hearing after flashing. Could this be an issue that rc9 didn't flash correctly?

        I wanted to double check so I flashed rc9 back on and it played the normal musical tones like I am used to hearing when flashing the firmware.

        • Developer


          We will have a look at your logs.  I've had a quick look but some on the dev team are more familiar with the EKF so I hope they'll help me out.

          The list of sounds are on this wiki page.  My guess is you heard the new IO board firmware sound.

          • Randy,

            I couldn't hold back and flashed rc9 again. This time making sure I got the correct tones after the firmware flash. I haven't tried and probably won't try anything with ekf enabled for a little while but it is flying remarkably well. When I flashed rc7 and rc9 when I didn't get the correct tones it was twitchy and the motors seemed to be noisier, I also noticed that the yaw would hunt around when in poshold. 

            For now I am going to write it off as a bad flash. Hopefully my log proves to be useful for the devs.

          • Thanks for the reply Randy. The sound I heard when I flashed back to 3.1.5 was the firmware loaded successfully and the one I am used to hearing when flashing firmware. The sound I heard after loading rc7 the one time I had an issue was the "startup ok" and the same with when I loaded rc9 last night it played the "startup ok" after flashing. 

            When I did the test with flashing back to 3.1.5 it played the "Firmware loaded successfully" and I remembered the tone sounded different when I had loaded rc9. So I flashed rc9 again and it played the "Firmware loaded successfully" tune. 

            Now I am unsure if I want to try rc9 again since it didn't play the correct sound maybe I had a bad flash? I am probably going to stay on 3.1.5 at least till after next weekend as I have an event I want to get some aerial footage with.

      • Here is a link to the video from the gimbal camera:

        You can tell when the ekf was turned off and immediately made a hard right front turn.

This reply was deleted.