Developer

ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Never know, I was in stabilize mode. Will try to get the logs if I can, PX4 is beat up pretty bad. Copter hit an overhead water pipe in my studio. Might sound insane to test inside but imagine if this was outside! Yikes!!!

          • Here is the log. Found  at least three errors: Flightmode 4, Failsafe Fence 1, AFE Fence 1. I attached the log. BTW, I never invoked the land command.

            2014-06-12 14-26-34 16.log

            https://storage.ning.com/topology/rest/1.0/file/get/3702823376?profile=original
            • Hope someone can shed some light on this issue as I really want to get in the with 3.2...just not like this. :-) Well this is what the test quad was built for and adventure was had by all.

              • Developer

                Andy,

                      I had a look at your logs and something went very wrong with the inertial nav altitude.  The scale is not great in the image below but in any case, the inertial nav altitude estimate is in green.  It bounces around between +20 and -60m for the first couple of minutes and then it shoots up like a rocket to 2.9km and then drops again to -600m.  This is certainly the cause of the behavior you saw:

                   a) When the alt climbed above 100m it triggered the altitude fence and switch to LAND mode.  Because it thought it was climbing it reduced the motors to their minimum and you saw the vehicle come down.  Even though your throttle was at zero, it didn't automatically disarm because it didn't think it had landed (because the climb rate   >500m/s).

                    b) when the inertial nav alt peaked and started falling, the vehicle now tried to slow it's descent by ramping up the motors and then it crashed into the ceiling.

                3702897493?profile=original     I've never seen this but I think the cause is your backup accelerometers haven't been calibrated.  We've added support for redundant accelerometers and gyros but we have not extended the pre-arm check to ensure that both are calibrated so we better add that!

                     We don't have a chorus of people running into this because most users of PX4/Pixhawk are new and so they wouldn't be carrying over their parameters from AC3.1.

                3702897097?profile=original     I'm very sorry for your troubles, we will confirm this is the issue put a warning at the top of this thread to tell people to redo their accel calibration and fix it for -rc3.

                • Thanks Randy! Always good to know exactly what caused something. Would a full recalibration be ok or should I hold off on trying 3.2 on this PX4 again?

                  Cheers,

                  Andy

                  • Frank. The only thing I tried was to go back to 3.1 but the quad flew terribly. The impact made contact between the PX4 and a water pipe. Not sure if the PX4 is toast. Will do a few more tests first.

                    Thanks for your update.

                    Cheers,

                    Andy

                  • Andy, did this work for you? I'm also having issues with altitude on PX4/PX4IO, even in 3.2-latest of june 11th. My report is on page 37 of this thread. In EKF-mode the altitude sticks at 15000 meters after a few minutes and in 'legacy'-(non-EKF) mode the altitude drops to a steady 0 meters after a few minutes.

                    And also @Randy: I was under the impression that PX4 does not have a backup accelerometer. After calibration in 3.2 (latest and rc2) INS_ACC2* all are zero.

                    Thanks for looking in to this!

                  • Developer

                    Andy,

                         I think if you connect your px4 as it is now (i.e. without the backup accels being calibrated) to your PC with the USB cable you'll see the altitude (via the mission planner) move all over the place especially if you lean the board.

                         If you re-do the accel calibration and repeat the test I think it'll be a-ok.

                         Thanks again for this important report.

  • been having a lot of fun with 3.2, both on a quad and y6. hybrid is fantastic!

    here's a vid, taking too much risk with release candidate software but I believe in it lol.

    • Nice place(where is it if not a secret?),nice confident video

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
yesterday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
More…