Arducopter + Bluetooth + Android tablet - help!

I need help (please) setting up connection between an Arducopter 2.8, an RCtimer bluetooth module, and an Android tablet running 4.4.2. I would like to plan and fly simple "missions" using the tablet only as the interface for mission planning - no need to control during flight - no long range communication needed.

I am about at the end of my rope with this - but we'll tuck that away now that that has been said.

The scratch built quadcopter flies great - no issues there. I can plan missions with MP over a USB connection with a PC and they execute as they should.

The bluetooth module is paired with and successfully links with the tablet - no issues there. I worked with the BAUD rate and I think but cannot be sure that this is not the problem. This might need more attention, maybe*.

*Setting BAUD rates has been a challenge because NONE of the guides I have found ANYWHERE accurately show the steps. They may be 100% correct but what showed up on my PC didn't match what the tutorials showed. I tried the Arduino + FTDI route but it did not do as it was described (failed at AT+send... no response regardless of anything tried.) The best perceived result was through Device Manager on my PC (via FTDI) but I can't say that was the right way to set the BAUD rate. Noob.

I have tried with and failed using Ardupilot and Droidplanner.

Ardupilot gets stuck at "No Vehicle", and offers no clues otherwise. It also thinks we are off the west coast of Africa and we are not. It's a nice program & I had it working with a Crius AIOP V2 board a while ago using the very same tablet and BT module!

Droidplanner gets stuck at a blue dot showing my accurate location. The blue dot moves with my tablet but does not follow the location of the quad - so it isn't getting a signal from the GPS on the quad. If I press the satellite image on the screen - as if to set a waypoint like in Mission Planner - a prompt appears "press OK to enter guided mode. To change locations, press and hold the map." If I press OK a message says "Bad GPS for guided". Also, there is a status bar at the top of the screen that shows obviously bad info about my GPS status and a few other things indicating a failed read.

There is a miserable shortage of information regarding the connection of the bluetooth module to the telemetry port but I did the best I could with the information I could find. The BT lights up and bonds without any smoke, so we're close. I have tried switching TX and RX connections with no difference in results.

For what it's worth, my own assessment is: For some reason the BT is not sharing the correct data with the tablet. It could be that the BT is happy with the tablet but not properly connected to the APM, or that the APM/BT connection is fine but it is not communicating properly with the tablet. The BAUD rate and the APM 2.8 telemetry wiring are top suspects.

I have searched for answers to this and and 100 other issues since getting into Aerial Robotics over 3 years ago. You all must know that although the answers have probably been covered in "another thread", finding that thread and hoping to get an answer can be like finding a needle in a haystack.

Any help is very much appreciated in advance!

MODS please help put this in the right place - thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • OBWAN,

    Please don't be offended but is your Android tablet truly paired with the blue tooth module or has it only discovered the module?

    • Hi,

      Working from my Android tablet; if I start Andropilot there is a "looking for radio" message with a button that says "bluetooth". When I press it, the BT module red LED goes solid and the message changes to "looking for vehicle". To me, this indicates a connection has been made between the tablet and the BT module.

      On the  Droidplanner app; I press "connect", the BT module red LED goes solid, but I get a "Satellite -1, NoFix" in the status bar at the top of the screen and it just fails from there.

      On the Tower app, I press "connect" and the BT LED goes solid but then the app sits there kinda stupid and doesn't indicate anything good or bad.

      My assessment at this point is the BT isn't really the problem but something isn't right between the APM and the BT module. But I can't find any clues about how to figure out the issue.

      Thanks so much for responding!


      • I GOT IT!!

        Working via PC/ bluetooth/ Mission planner I tried again and again numerous times with either a "No heartbeat packets received" error, or "Connection failed" error. I can't be sure of whether or not this is what finally made it connect, but I was on the bluetooth setup page in MP, had renamed the connection, the baud was at 57600 and I changed the pin to 0000. Normally trying to save this failed with a "select com port" error. This time while trying to connect, just as the BT module light went solid red I clicked "save" on the BT setup and BAM it connected just like normal. Now it connects without any tricks. The more exciting thing is that now it also connects perfectly with my tablet via Andropilot!

        I'm all set. Thanks for offering help.

        • Hi OBwan

          I wonder whether you have loooked at Dennis Balwin's videos?

           There are several videos related to the Bluetooth /3DR setup. I found them very usefull.

          By the way, have you altered your RCTimer Minim OSD so that you can power it from the 5V end only?

          I found that it simplifies the setup and means you dont have to use a 12V Ubec to power the Minim if you use 4S batteries.

          Best DP

          • Hi David,

            I had not seen D. Baldwin's videos, but they look like a good resource for when I move on to telemetry control. Right now I am only interested in creating missions before flight and then launching them - not controlling via tablet/ bluetooth during flight. Also, while I have a Minim OSD on standby, I have not installed it on anything yet. I'll  keep your note on a 5V setup in mind. Thanks.


            • Hi OBwan

              Strange that this link didn't appear on my previous post:


              This illustrates how to 'gypo' the RCTimet board, without the solder pads shown on the Ardupilot wiki page for the Minim.

              He has other very useful and informative stuff on his Youtube channel too.

              Best DP.

  • Developer

    you should check this page

    You need to serial interface on the bluetooth module set 57600

    Without any specific information on the module it's hard to say what the issue is.

    You can test the module using your ftdi cable to see if data is coming from the serial port on the bluetooth adapter, or make it 'loopback' (see troubleshooting section in above link)

    • Hi Bill,

      I had worked with the info on the link you provided before. I ran through it again just now. As far as I can tell the baud rate is correctly set to 57600, the SPP com port box is checked, my PC has paired with the BT module (RCtimer bluetooth module), the APM reset on USB connect box is unchecked in Mission Planner. The designated Com Port is COM11.  When I try to connect (to COM11 @57600), during the countdown the BT module red LED is solid (not blinking). MP returns the error "No heartbeat packets received".  I have not tried working with the loopback test.

      At the moment I am not working with the Android tablet at all - just going for the connection from PC BT to the RCtimer/ APM BT.

      Oh, and I apologize for the slow response - I have precious little time to "play" with my quadcopter and other stuff. I sincerely appreciate that you have offered to help. I am actually out of time for tonight but will be checking for any response from you ASAP tomorrow.



      • Developer

        The baud rate to the BT model from Windows is irrelevant.

        The baud rate that matters is the serial port between the Bluetooth Module and the APM2.x HW.

        The APM telemetry port is set at 57600 (that's the default). 

        If you have this RCTimer unit its 115200 according to the website

        You could try changing SERIAL1_BAUD on the APM to 115 and see if that makes it work. (Use the Full Param List) 

        The other option is to connect a FTDI cable to the serial port of the bluetooth module and entering the appropriate AT command to set it to 57600 as default. Since i don't know the make and model of the bluetooth module I can advise (its' probably the same as the previous link I posted)

        Multiwii MWC FC Bluetooth Module Use For Android
        RCTimer - the world's No1 Online Hobby Store. We stock a huge selection of RC products from Planes right through to Quadcopters and all accessories.…
        • Possible progress. BT baud was not set to 57600. This time I was able to reset it via Arduino with the AT+buaud7 command. Attempts to do this before always failed, but this time it worked. Now to test connectivity... when I get a chance. Off to work I go.


This reply was deleted.