After verifying that Altitude hold and loiter was working properly (without any toilet bowls) I tried the Auto mode with horrible results. 

Checking the logs it seemed like the copter thought it was about half a kilometer away when it got out of control. 

I also checked the HDOP of our location and it was under 2 at the time we were flying (HDOP is always under 3)

I have attached logs from two of our flights in auto mode. 

Thank you for helping. 

edit 3/3/15:

This problem is mostly fixed:

What I did:

1. I used a new GPS module (same model) and mounted it on one of the arms that are farther away from the receiver (south west arm in the picture, if up is North)

2. I used autotune mode to tune the stabilize gains (http://copter.ardupilot.com/wiki/autotune/)

3. I set the throttle to the mid position (http://copter.ardupilot.com/wiki/ac_throttlemid/)

Attached is a flight log with these changes. I do not get GPS glitches now but RTL brings the copter back to about 5 meters west of where it starts. Any help would be greatly appreciated. 

Below is the flight path:

Views: 844

Attachments:

Reply to This

Replies to This Discussion

Is like you lost sats for moments, 3 HDOP is very high, you need under 2.

It does this almost all of the time when we fly in Auto mode. What would you suggest we do?
Maybe try a new module? Or change the position of the gps module?

where you have the gps? can you share a photo?, do you have the camera or fpv near the gps? is like something is interfering it

 

Its mounted about 1 1/2 inches above the main frame of F450.

I did add an external compass right next to the gps module. 

Cameras or fpv near? where you flying near trees buildings or any obstacle? try to fly near and observe the logs if repeat this, do you have another gps wire to try? I saw many problems with them.

We are flying on a soccer field with no buildings near by. 

We don't have a camera or a FPV gear attached to the vehicle. 

The rx, though, is only about an inch away from the gps. Could that be the issue?

I don't think, check if repeat the issue, some days is a sats problems, not yours, but it's repeat frecuently you can try with another cable or if persist the problem, if you have, with another gps; if you don't have a ground control station, when you arrive to the place to fly first of all connect your cuad to give time to pick good sats, at least some minutes after an automatic flying, if you have a tablet or android verify your sats and HDop, min 8-9 sats and hdop under 2.

What's not making sense here is that it only glitches in auto mode.  If this was satellite disruption or atmospheric, it would be happening regardless of flight mode.  Are you sure this doesn't happen in Loiter mode or Position Hold modes?

That is what we are experiencing. 

I have attached two more flight logs to this message. 

Thank you for your help.

Attachments:

Any luck??

Which software did you use to create and send the mission to the drone? If the only issue is in auto might be a problem with the mission itself is corrupted. Have you tried starting from scratch and write another simple mission?

We tried two missions and both were from the mission planner software. 

This problem has actually been partially solved see response below for details. Thank you for helping.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service