Arducopter incessantly yawing

Hey All,

I have been playing around with my Arducopter for a month or two now and it has been performing well. However, since last week it has started yawing like crazy. It tilts while taking off and then starts spinning rapidly in the air. I have flied with and without SIMPLE in the STABILIZE mode. Here are the steps I have taken:

1) Tried Firmwares 2.3 and 2.5.3

2) Erased EEPROM, reset the board

3) Leveled the quad multiple times.

4) Calibrated the compass using the new Mission Planner with Live Data as well as with a tlog.

5) Ensured the power board is connected to the right ESCs and the right motors

6) Checked motors directions are correct

7) Motors are mounted securely and vertically on the arm

8) Made sure the center of mass is almost dead center

I am using the standard 3DR quadrotor frame. I initially suspected the magnetometer (compass) as the issue. However when I disable the compass and fly without SIMPLE it continues to yaw.

Any help would be greatly appreciated. I am losing my head over this issue.

Thanks

Ammar

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have same issue right now. Seems like tried everything, but it's still yawing like crazy. Did you eventually solve your problem?

  • If you disable the compass, it's been mentioned to disconnect GPS. Run the CLI compass test as Chris mentioned--let it run for a few minutes--I had periodic "not healthy" values reported over time on another unit. Do a wiggle test on the compass solder joints. Make sure the compass gets 4.9V or more. That other unit I had reported 4.81V and the compass normally failed over time(e.g. not healthy reports)--moved the compass to a new oil pan with the right volts and viola--compass was fine.

    If you have wireless telemetry, run mission planner and generate a tlog. Observe the red and black lines. Red should follow the compass (e.g. front of the APM), black should show you the direction of your vehicle (GPS vector).  In my case, the black line followed the yawing, but red held--looks like a compass issue.

    If the CLI tests show nothing it's likely in-flight interference from your xbee (if you have) or battery cables. Try moving your GPS antenna, xbee or batt leads.

    Hmmm. interesting. I just finished building a custom frame hexa last week, flew fine on Fri & Sat. But today was another story--same issue of yaw drift!... to the point I almost crashed in a parking lot as well as a railroad track--I was in auto and it just "spun away". I was able to go into stab mode and "circle" it back. Thank god we can fly upto 400ft!

  • 3D Robotics

    Sounds like a hardware issue. Have you checked your sensors in the CLI test suite?

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…