ArduCopter motor command and take-off issues

Hello team,Thanks for all the support thus far on building my first arducopter.Yesterday, I had finally completed the frame, uploaded the recent ArdupiratesNG code, calibrated my ESCs, checked motor directions, calibrated the TX through configurator, calibrated accel sensors, etc.It seemed as if all was ready to go, so I prepared for a pre-flight check with no props and armed the motors. (I have Xbees enabled and relaying data back to configurator wirelessly). Immediately, configurator showed the 4 motors jump from "1040" to "1100" (motors not spinning). This seemed correct as the quad was now armed.Now heres the trick, As I increased the throttle to say around 20%, at first the Front and Rear motors would increase to about 1200 but then drop down to 1100 and stop running. At the same time, the other 2 motors (Left and Right), would continue to gain power until the reach around 1400.Now I tried increasing throttle to 50%, and a similar situation occured. This time, the Front and Rear motors reached around 1450 before they started dropping back down to around 1200 (Spinning but Low RPM). The other two motors (Left and Right) continued to gain power until they reached around 1750.My first reaction was to check trims (which were all 0), and recalibrate, but to no avail. It seems as if the quad is trying to overcompensate for a shift in yaw even though there is no movement and the quad is on a flat surface. Maybe this is a PID issue??Configurator is reporting that all accels and gyros are fluctuating between -1 and 1 on the flat surface (with the exception of Z which is ~408) with no throttle and of course a little more fluctuation when the motors are running bc of vibration.I am using Turnigy 25A Sentry ESCs and the 880kv 2836/9 Outrunners. I do not want to put the props on until its ready to fly. Thanks in advance :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • You guys gave me a confidence boost so I put the props on and tried away!

    First attempt I slowly crept the throttle up and it seemed like what was happening earlier was happening now, the quad was yawing while trying to take off. Finally, it took off but immediatly tried to dive to one spot so I brought throttle down to 0 and reset.

    I kept trying to take off but the same thing occured, quad would get off the ground about a foot, while yawing, and eventually tip over to one side.

    Not sure if this issue is related to the previous or if this is a completly unrelated one. Configurator is reporting the same conditions, 2 motors increase while 2 decrease.

  • Thanks for all the responses. I double checked the yaw on the transmitter and verified that it was at 1500. But what you guys are saying sounds logical, the quad is detecting that yaw is not centered so it tries to correct this. But if the issue is not in the transmitter, where could it be coming from? Yaw sensors perhaps?
  • it's not a PID problem

    go to transmitter adjust screen, check if yaw channel is 1500, if not, trim it to get it there

  • Hi

    I think I had the same problem with my first flights yesterday. I think it's a PID issue. I found that if I held the copter above my head for a few seconds after throttling up the motors, then throttled back I could take off okay, but it still takes a couple of second to fully stabilise in the air, did not need to move the trims.

    Be interested to see what other people say.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…