Two Saturdays ago I spent the afternoon assembling and configuring my first arducopter - yay (all stock - frame, motors, ESCs, boards, Turnigy 9x radio).  I was surprised at how quickly it all came together (approximate build/soldering time 2-3 hours). 

 

Then I got around to 'arming the motors' and I got stuck... real bad.  I loaded and reloaded the code(RC2) ran Configurator and CLI many times, calibrated and recalibtated ESCs.  I disassembled and reassembled everything. I broke out the multimeter, oscilloscope, spectrum analyzer and the like. I ran through every conceivable mode and setting on my Tx and even took it apart. 

 

As a last resort I came to to this forum (I like to troubleshoot and dissect problems the hard way first).

It took me about two weeks - I read through almost every forum discussion relating to arducopter motors and configuration - several hundred pages.  I observed a common theme - almost all threads on motors not arming contain comments with basic instructions/troubleshooting tips from the manual and wiki.  95% of these conversations end with the thread's author resolving to buy new hardware or keep trying - no solutions anywhere to be found. 

 

After countless hours of reading I came upon a single comment (I've forgotten the member's name now and can't go back in my search history b/c I just updaed to Firefox 4 - but thank you whoever you are) that solved my problem:

 

In order to arm the motors using my radio  (Turnigy 9x aka Eurgle, FlySky, iMax, etc - an inexpensive but popular model here) I had to hold my throttle AND yaw controls down and to the right (throttle is on the right and yaw to the left in default mode 1 on Turnigy 9x).

 

Again, if your motors are not arming properly, try moving the yaw stick to the lower right position along with the throttle to arm.

 

A word of caution: I still don't know if there is a better solution to all this, but my maiden flight consisted of the quad doing a violent violent backflip and snapping two props.  This is because I returned my throttle to the neutral position before the yaw, completing the arming process with quad responding to the yaw stick posiion.  My solution is to move yaw to the center position then let the throttle go.

 

I kept a pretty detailed step by step build log with a few observations and tips that might help with first builds - I'll get around to posting it eventually.  Also, a few tools and materials not listed in manual or included in the kits (most notably single fem to fem connectors and a GPS cable long enough to reach the top of the dome).

 

Hope this helps and any input is appreciated - happy flying!

 

 

 

Views: 8874

Reply to This

Replies to This Discussion

That is a standard safety on most (all?) radios.BTW the standard dis-arm is to hold the throttle to the bottom left for several seconds.
To be clear, standard default arm/disarm is throttle only - for Turnigy 9x with Arducopter, I had to move both throttle and yaw (which are right and left sticks respectively in default mode 1) - I prefer using mode two (Throttle and yaw controlled by left stick).
Ah--you're flying Mode 1! ArduCopter is designed for Mode 2 (the standard in North America). We'll have to make that clear in the documentation. Thanks for the heads up!
I'll be damned - learn something new every day. Like I said above, I think there are a lot of guys stuck on this same issue of arming motors who aren't using mode two.
How did you end up with a Mode 1 RC transmitter? I didn't even know they were sold in the US.
I thought this is what most Arducopter operators here were using - Turnigy 9x from Hobby King? Seen it come up on the blog several times.
http://www.hobbyking.com/hobbyking/store/uh_viewitem.asp?idproduct=...
That Turnigy 9x comes in two varieties: Mode 1 and Mode 2. I think you ordered the wrong one. You should have picked this one.
Thank You Chris - knowing is half the battle.
I had this problem, I just swapped the RC channels on the receiver so that the throttle and yaw were on the same sticks.

Thank you for the tip, shannon.

I am in Mode 3 :

Arm : Pitch up Roll right

Desarm : Throttle down Rudder Left

Strange but it works

Thanks! That helped a lot! But I still can't arm my heli, unless I use mission planner. Maybe if somebody here knows the logic of arming i.e. what PWM values in what channels makes it arm/disarm, I believe it would really be of use for us.

Found my answer here:

http://diydrones.com/forum/topics/arducopter-2-9-for-tradheli-discu...

Channel 8 is the key in order to arm/disarm the heli! As I'm not using ch8, I lowered all the values (RC8_MAX = 800, RC8_MIN = 800, RC8_TRIM = 800). Now it works like a charm!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service