Arducopter was working fine, until .... help!

My friends and I are building an Arducopter.

I was doing a  pre- flight check and everything seemed to be working, pid was responsive transmitter commands was working fine. 

Then i uploaded the latest code...

And now the speed controllers/motors are not arming. So this is confusing the hell outa me.. the speed controllers work by them selves(hooked up to a transmitter). I checked the pwm outputs to the ESC inputs they are all connected .. yet when I arm it, (no throttle, full yaw right. the LED indicates stable mode..(slow blinking) yet the speed controllers are not arming..

im using thunderbird 18 amp speedcontrollers.. it was working fine then it decided to be weird since i uploaded new code..

after trouble shooting alot of it, i think somewhere in my arduino 21 the libraries are all mixed up and some code is not being uploaded properly... is there anything else i can trouble shoot, get an osiloscope? an exorcist? 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Try reloading the code. If that does not work go back to the original code and version of arduino you were using and try that again.

    Can you connect to the 'copter using the Configurator ?

    If the code loading was done successfully Arduino reports 'Done Uploading'.

    What version of the code did you go from/to? Do you need to re-initialise the EEPROM and redo the software and transmitter calibration?

    Peter
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
11 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…