ArduPilot EEPROM define

novice level - latest H/W and S/W. Anyone have knowledge of the following behavior?


I finshed A/P IMU and Airframe integration Fine . Good response to Tx control inputs.

Tried to reload software.  The IMU reload was OK.

The standalone reload of the A/P would not complet.  It immediately stopped on the graound start part of the flow  with an error "ground_start" not defined.

I tried the original  unmodified Config which had been saved and had the same result.  Will begin all available means of troubleshooting but if someone has a clue about a srortcut. It would be helpfful.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • A careful repeat of the instructions from the beginning cured the problem  Which was caused by my copying the configuration file and pasting it into the flight OFP file.

    For other newbies I offer these two lessons learned


    (1)  I used a lot of paper and drew detailed flow diagrams for the Load Software instructions.  This clarified the roles and locations of the .h and .pde files to the point I could identify what was happening and what should happen and keeping oriented over an activity timespan measured in days. Don't smile.  The great majority of pilots in my flying club are retired. No one else can afford $25000 turbojet F-15s!


    (2)COM Port - When checking in the IDE tools menu for COM Port - understand that the COM Port assignment for the new virtual serial Bus port will not display if the FTDI is not connected to a powered up ArduPilot. The DIY instructions are correct but in my newbie case - it was 2 days between when the power got turned on (subsequently off) and when I got around to loading the config file.



This reply was deleted.