Hi, I recently bought ArduPilot with an IMU and a shield for my EasyStar.

I have wired it up like the guide on the Google Code page showed.

 

When I turn it on to test it, I can move the plane an the control surfaces will counter move like they should in the stabilizing mode. And the MUX light turns on and off like it should.

 

But then suddenly, all lights on all the boards, including the receiver go completely crazy.

All servos stop dead for a couple of seconds before they go completely of the hook, even the elevator servo broke loose from the fuse ones.

The plane doesn't respond on any of the commands from the transmitter. I'm not even able to turn of the MUX, and even when the MUX-light turns off, the servos still behave like chikens without heads.

Sometimes it even throttles up.

 

The only thing that seems to help a bit is shutting off the transmitter, then it stops. But when I turn the transmitter on again, same problem.

This problem has also happened after the transmitter was turned off, but I only experienced this ones.

 

The only thing I can do to stop it, is pull out the battery and wait a couple of minutes. Put it in again after a few seconds doesn't help.

 

I have removed the shield and tried again without luck, I have checked the wiring, I have even twined the servo wires and tried to removed any possible interference but nothing seems to helps.

 

I have the newest code, but I don't think it is the code because stabilizing mode seems to work flawless until something triggers it to go wild.

 

I can't fly it in manual mode either, because when this problem suddenly kicks in, it even jams it in manual mode.

 

There is no radio interference that triggers this problem, of that I'm sure.

 

My Tx/Rx is a Hitec Optic 6 Sport with Hitec HFD-08RO (35 MHz) and I haven't had any problems with them before.

 

I haven't been able to fined any post about the same problem. I have found a few with the same symptoms, but never quit the same problem.

 

Hope somebody can help, thanks.

 

 

(Conclusion: If you don't bother to read this thread, this problem was caused by a bad Rx. After changing the Rx everything works fine.) 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Symptoms very suggestive of a bad Rx, probably loose or damaged crystal if it is that kind of Rx. You say it survived two crashes, that may explain it. Ancient RC mantra says to always replace crystal after crash.

     

  • Alright, now I have got the TURNIGY Sentry 25amp ESC. Testing it without ArduPilot everything seems fine. The motor even runs smoother with this ESC.

    It delivers a steady 5V to the Rx.

     

    But then I hooked up ArduPilot, checked if everything was alright and plugged in the battery.

    BOOM, both servos get full power to one side, and just keeps going while grind of the teeth off the servo cogs.

    Okay, so I quickly pulled out the battery, and with my servo cogs already ruined I tried ones more.

    Same result, but this time also the throttle got jammed full open.

     

    This happens immediately the plane gets power. The MUX is off, and the ESC hasn't even time to start properly.

     

    I tried again without ArduPilot and everything works fine.

     

    Now, in the manual it says «Input 1 should go to your receiver's Channel 1 (aileron)».

    I don't understand why, so I put the input 1 into the rudder channel like I think it should be.

    After some thinking time I tried it like its written in the manual: «Input 1 should go to your receiver's Channel 1 (aileron)», and put power on it again.

    Surprisingly ArduPilot seemed to work fine.

    Well except I have to use the aileron control to move the rudder, and the prop spins a 2-3 rounds every 10 sec.

     

    I took a video of this:

     

     

    So I switched back to the rudder channel, and this time it still behaved almost like the problem in the beginning of this thread, but not as violent.

    But when I turned on the MUX it seemed to work properly.

     

    Still on the rudder channel I tried another time. This time the servos went completely bonkers. But again, turning on the MUX works properly.

     

    Here is a video of that:

     

     

    I first thought it was a short circuit in the Rx, so every servo lead got a signal, but the MUX works so I don't think its that.

    I more or less suspect there is something wrong on the board.

    But after looking at all the solders and it doesn't look like there are any short circuit there either.

     

    I don't think it is interference, then it should be just as bad with the MUX on.

  • Developer

    what code did you load?

     

  • 3D Robotics
    Could also be a power issue. How are you powering the board?
  • You seem fairly certain that it isn't radio interference, but it sounds somewhat similar to a radio problem I once had on 72mhz. I would remove the AP from the plane and test with just the RC hardware (receiver and servos) and see what happens. some aligator clips and a voltmeter to the servo rail to monitor if you have a constant 5V to the RX might help also.

     

    I think this could also be a bad battery, perhaps dropping voltage lower than nominal for your receiver.

     

    If it were me, I would test the AP by loading the HIL simulator code (I'm not certain that exists for original AP?) and see how it behaves in the simulator with just the receiver connected. If after several flights that is ok, connect servos to the APM and continue testing. The servos should respond just as they would in the plane.

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…