Hello All,

Getting a setup going. Everything appears to be working well, except the throttle.

Obviously, going straight into the Rx works just fine.

The ESC normally plays a startup tone, and then 3 beeps to let me know it's ready. It does this when going straight into the Rx.

If I jump the Rx into the "in" side of ardupilot.

And hook the ESC into channel 3 on "out" side.

I get the startup tone, but not the following three beeps.

Has anyone else experienced something like this?

I've quadruple checked the servo connections, and they're correct.

Any suggestions?

Thank you!

John C.

Views: 1085

Reply to This

Replies to This Discussion


I believe that the ESC is looking for a throttle control signal which it gets from the Rx at power up.

What position do you have your Ardupilot CNTL signal at when powering up? It should be in manual. Looks like the throttle control signal is not being passed through the Ardupilot mux from the Rx when in manual.

Just a thought.

Sounds like you need to adjust the minimum throttle servo value in the header file to a lower value. I am not familiar with the Plush, but most speed controllers will not arm unless they see a low enough throttle signal (i.e. stick all the way down). If you want to test this idea hook the esc up to the rx and start it up at say 1/4 stick. If you get the same behaviour then this is what is happening and what you need to adjust. Just be careful in case the Plush does not have this feature in which case your prop will spin!
Oh yeah, Thomas offers a better answer. However, I do run my setup so that for fast descent rates the ArduPilot does drop the throttle all the way to zero RPM. You do need a correct minimum value in the header file to do this.
Thanks for the reply Thomas!

I absolutely have the CNTL signal set in manual mode. Good thought.

I assume you soldered the jumper wire so channel 3 is enabled?
Been messing around with this...in my current easystar.h

#define throttle_max 1800 //Servo range In milliseconds.
#define throttle_min 1200 //

I set throttle_min to 0, just for grins, and now I'm getting this getsync error


Going to reboot, start over, and see what happens.

Yes, soldered into Mux3.

Able to cleanly upload now.

Perhaps my startup procedure is wrong.

1) Turn on Tx with ardupilot set to off and throttle stick at 0
2) Plug in Ardupilot through ESC via common battery
3) GPS lock
4) solid pwr and lock, flashing ST
5) startup rudder and elevator cycling
6) remove bind plug
7) rudder / elevator respond normally
8) no throttle response.

Would reversing the channel on my Tx make a difference?


So, I've done a little more troubleshooting, and still come up short.

Went after it with a multi-meter, and everything seemed to check out.

Set throttle_min from 0 to 1200, and got no changes.

Still not getting the startup 3 beeps after the initial tune.

This is the one I'm using.


Are there any other settings in the .h file that will affect the throttle signal going to the ESC?

Should I start looking at ESC programming variables?


Have done some more trouble-shooting...

Servo driver straight into the ESC powers the motor up nicely.

With a servo jumper (I've tried multiple ones) between the servo driver and the "in" side of the board, and the ESC on the "out" side of the board, I get nothing.

If I ohm the white signal wire with everything off, I get infinity on mux2, but it doesn't get there on mux3 (throttle).

The solder joints don't look bad, I assume you guys are going to tell me to touch them up.

Could it be the board itself?

Thank you!

John C.
Can you upload a photo of your board, close enough so I can see the wiring?

BTW, I don't what you mean by "servo driver" or "servo jumper"
Sure! I assume you mean the underside of the board.

By servo driver, I mean one of these:

By servo jumper, I simply mean a female to female cable that is used to hook the receiver outputs to the inputs of the ardupilot.

If I hook that servo driver straight into the ESC cable (the one with the green donut) the motor spins right up. If I hook it up like in the picture above, with the board powered up (autopilot switch off) I get nothing.

Thanks for the assistance!

John C.

The board looks like it's hooked up right. I don't really know what the problem is. We've sold thousands of these boards and I've never heard of an issue like this before that wasn't a soldering error of some sort or a funky RC system. But since yours is working fine for the other channels I'm stumped...

BTW, the MUX is straight physical pass-through in manual mode, so there can't be any code issues.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service